summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libunwind')
-rw-r--r--sys-libs/libunwind/libunwind-1.1-r1.ebuild4
-rw-r--r--sys-libs/libunwind/libunwind-1.2_rc1.ebuild4
2 files changed, 2 insertions, 6 deletions
diff --git a/sys-libs/libunwind/libunwind-1.1-r1.ebuild b/sys-libs/libunwind/libunwind-1.1-r1.ebuild
index 5403e331909d..03557aca160a 100644
--- a/sys-libs/libunwind/libunwind-1.1-r1.ebuild
+++ b/sys-libs/libunwind/libunwind-1.1-r1.ebuild
@@ -42,8 +42,6 @@ src_prepare() {
}
src_configure() {
- # do not $(use_enable) because the configure.in is broken and parses
- # --disable-debug the same as --enable-debug.
# https://savannah.nongnu.org/bugs/index.php?34324
# --enable-cxx-exceptions: always enable it, headers provide the interface
# and on some archs it is disabled by default causing a mismatch between the
@@ -58,7 +56,7 @@ src_configure() {
$(use_enable lzma minidebuginfo) \
$(use_enable static-libs static) \
$(use_enable debug conservative_checks) \
- $(use debug && echo --enable-debug)
+ $(use_enable debug)
}
src_test() {
diff --git a/sys-libs/libunwind/libunwind-1.2_rc1.ebuild b/sys-libs/libunwind/libunwind-1.2_rc1.ebuild
index e3d819d9c6d0..124f64844936 100644
--- a/sys-libs/libunwind/libunwind-1.2_rc1.ebuild
+++ b/sys-libs/libunwind/libunwind-1.2_rc1.ebuild
@@ -37,8 +37,6 @@ src_prepare() {
}
src_configure() {
- # do not $(use_enable) because the configure.in is broken and parses
- # --disable-debug the same as --enable-debug.
# https://savannah.nongnu.org/bugs/index.php?34324
# --enable-cxx-exceptions: always enable it, headers provide the interface
# and on some archs it is disabled by default causing a mismatch between the
@@ -57,7 +55,7 @@ src_configure() {
$(use_enable lzma minidebuginfo) \
$(use_enable static-libs static) \
$(use_enable debug conservative_checks) \
- $(use debug && echo --enable-debug)
+ $(use_enable debug)
}
src_test() {