summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/mars')
-rw-r--r--sys-libs/mars/Manifest1
-rw-r--r--sys-libs/mars/mars-1.0.1.ebuild42
-rw-r--r--sys-libs/mars/metadata.xml7
3 files changed, 50 insertions, 0 deletions
diff --git a/sys-libs/mars/Manifest b/sys-libs/mars/Manifest
new file mode 100644
index 000000000000..815be56211b4
--- /dev/null
+++ b/sys-libs/mars/Manifest
@@ -0,0 +1 @@
+DIST mars-src-1.0.1.tar.gz 1264844 RMD160 44d6ac117c72a69e4d9282e45a72b2ada4583f5f SHA1 3aae04c489947acad8874e8a79b2e1b2972912a0 SHA256 f61e60fb219c265344e65f34976cd5db2ea55dea05b51fd7107d50f263dd5234
diff --git a/sys-libs/mars/mars-1.0.1.ebuild b/sys-libs/mars/mars-1.0.1.ebuild
new file mode 100644
index 000000000000..715f69aca959
--- /dev/null
+++ b/sys-libs/mars/mars-1.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools
+
+MY_P=${P/mars/mars-src}
+
+DESCRIPTION="Multicore Application Runtime System"
+HOMEPAGE="ftp://ftp.infradead.org/pub/Sony-PS3/mars/"
+SRC_URI="ftp://ftp.infradead.org/pub/Sony-PS3/mars/1.0.1/${MY_P}.tar.gz"
+
+LICENSE="MIT_Plus MIT"
+SLOT="0"
+KEYWORDS="~ppc64"
+IUSE=""
+
+DEPEND="sys-libs/libspe2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/core"
+
+src_unpack () {
+ unpack ${A}
+ cd "${S}"
+ # repeat after me: "dummy tuples are bogus"
+ sed -i -e "s:/spu:/spu-elf:" \
+ -e "s:--host=spu:--host=spu-elf:" configure.ac
+ eautoreconf
+}
+
+src_compile () {
+ unset CFLAGS
+ unset CXXFLAGS
+ unset CFLAGS_ppc64
+ econf --with-mars-platform=cell || die
+ emake || die
+}
+
+src_install () {
+ emake -j1 DESTDIR="${D}" install
+}
diff --git a/sys-libs/mars/metadata.xml b/sys-libs/mars/metadata.xml
new file mode 100644
index 000000000000..6eb35690d41d
--- /dev/null
+++ b/sys-libs/mars/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>lu_zero@gentoo.org</email>
+</maintainer>
+</pkgmetadata>