summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/musl-nscd/musl-nscd-9999.ebuild')
-rw-r--r--sys-libs/musl-nscd/musl-nscd-9999.ebuild23
1 files changed, 18 insertions, 5 deletions
diff --git a/sys-libs/musl-nscd/musl-nscd-9999.ebuild b/sys-libs/musl-nscd/musl-nscd-9999.ebuild
index cdee80a89452..b47444961d2f 100644
--- a/sys-libs/musl-nscd/musl-nscd-9999.ebuild
+++ b/sys-libs/musl-nscd/musl-nscd-9999.ebuild
@@ -1,19 +1,32 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit git-r3 systemd
+inherit systemd
DESCRIPTION="musl-nscd is an implementation of the NSCD protocol for the musl libc"
HOMEPAGE="https://github.com/pikhq/musl-nscd"
-EGIT_REPO_URI="https://github.com/pikhq/musl-nscd"
-EGIT_BRANCH=master
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pikhq/musl-nscd"
+ EGIT_BRANCH=master
+else
+ SRC_URI="https://github.com/pikhq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="MIT"
SLOT="0"
IUSE="minimal"
+src_prepare() {
+ eapply_user
+
+ sed -i '/LDFLAGS_AUTO=-s/d' configure || die 'Cannot patch configure file'
+}
+
src_install() {
if use minimal; then
emake DESTDIR="${D}" install-headers