summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/rpmatch-standalone')
-rw-r--r--sys-libs/rpmatch-standalone/metadata.xml2
-rw-r--r--sys-libs/rpmatch-standalone/rpmatch-standalone-1.0-r1.ebuild (renamed from sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild)17
2 files changed, 8 insertions, 11 deletions
diff --git a/sys-libs/rpmatch-standalone/metadata.xml b/sys-libs/rpmatch-standalone/metadata.xml
index 67cf88841b35..4f03b2908d47 100644
--- a/sys-libs/rpmatch-standalone/metadata.xml
+++ b/sys-libs/rpmatch-standalone/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>blueness@gentoo.org</email>
diff --git a/sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild b/sys-libs/rpmatch-standalone/rpmatch-standalone-1.0-r1.ebuild
index 4881a46decc1..2f8ee77c2482 100644
--- a/sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild
+++ b/sys-libs/rpmatch-standalone/rpmatch-standalone-1.0-r1.ebuild
@@ -1,24 +1,21 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
DESCRIPTION="Standalone rpmatch library for use with musl"
HOMEPAGE="https://github.com/pullmoll/musl-rpmatch"
SRC_URI="https://github.com/pullmoll/musl-rpmatch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/musl-rpmatch-${PV}"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 ~riscv x86"
IUSE="static-libs"
-DEPEND="
- !sys-libs/glibc
- !sys-libs/uclibc"
-
-S="${WORKDIR}/musl-rpmatch-${PV}"
+RDEPEND="!sys-libs/glibc"
src_prepare() {
default
@@ -34,6 +31,6 @@ src_install() {
default
find "${D}" -name '*.la' -delete || die
- mkdir "${ED%/}"/usr/$(get_libdir)/pkgconfig/
- cp "${S}"/musl-rpmatch.pc "${ED%/}"/usr/$(get_libdir)/pkgconfig/rpmatch-standalone.pc
+ insinto /usr/$(get_libdir)/pkgconfig/
+ newins musl-rpmatch.pc ${PN}.pc
}