summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/atop/atop-1.27_p3.ebuild')
-rw-r--r--sys-process/atop/atop-1.27_p3.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/sys-process/atop/atop-1.27_p3.ebuild b/sys-process/atop/atop-1.27_p3.ebuild
deleted file mode 100644
index 7e615c59c184..000000000000
--- a/sys-process/atop/atop-1.27_p3.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="3"
-
-inherit eutils toolchain-funcs
-
-MY_PV=${PV//_p/-}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Resource-specific view of processes"
-HOMEPAGE="https://www.atoptool.nl/"
-SRC_URI="https://www.atoptool.nl/download/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm hppa ~mips ppc ~ppc64 x86"
-IUSE=""
-
-DEPEND="sys-process/acct"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- sed -i \
- -e '/^CFLAGS/s: = -O : += :' \
- -e '/^LDFLAGS/s: = : += :' \
- -e 's:\<cc\>:$(CC):' \
- Makefile
- tc-export CC
- cp "${FILESDIR}"/atop.rc atop.init
- chmod a+rx atop.init
- sed -i 's: root : :' atop.cron #191926
-}
-
-src_install() {
- emake DESTDIR="${D}" INIPATH=/etc/init.d install || die
- # useless -${PV} copies ?
- rm -f "${D}"/usr/bin/atop*-${PV}
- dodoc README "${D}"/etc/cron.d/*
- rm -r "${D}"/etc/cron.d || die
-}