summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/libcrypt/libcrypt-2-r1.ebuild')
-rw-r--r--virtual/libcrypt/libcrypt-2-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/virtual/libcrypt/libcrypt-2-r1.ebuild b/virtual/libcrypt/libcrypt-2-r1.ebuild
new file mode 100644
index 000000000000..ffb273b29297
--- /dev/null
+++ b/virtual/libcrypt/libcrypt-2-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for libcrypt.so"
+
+SLOT="0/2"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="static-libs"
+
+RDEPEND="
+ !prefix-guest? (
+ elibc_glibc? ( sys-libs/libxcrypt[system(-),static-libs(-)?,${MULTILIB_USEDEP}] )
+ elibc_musl? ( sys-libs/libxcrypt[system(-),static-libs(-)?] )
+ )
+"