summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/python-futures/python-futures-1.ebuild')
-rw-r--r--virtual/python-futures/python-futures-1.ebuild16
1 files changed, 16 insertions, 0 deletions
diff --git a/virtual/python-futures/python-futures-1.ebuild b/virtual/python-futures/python-futures-1.ebuild
new file mode 100644
index 000000000000..5519243b769b
--- /dev/null
+++ b/virtual/python-futures/python-futures-1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for the Python concurrent.futures module"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' python2_7 pypy)"