summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/rust')
-rw-r--r--virtual/rust/metadata.xml27
-rw-r--r--virtual/rust/rust-1.34.2.ebuild15
-rw-r--r--virtual/rust/rust-1.35.0.ebuild15
-rw-r--r--virtual/rust/rust-1.36.0.ebuild15
-rw-r--r--virtual/rust/rust-1.37.0.ebuild15
-rw-r--r--virtual/rust/rust-1.71.0-r2.ebuild23
-rw-r--r--virtual/rust/rust-1.71.1-r2.ebuild23
-rw-r--r--virtual/rust/rust-1.73.0-r1.ebuild23
-rw-r--r--virtual/rust/rust-1.74.1-r1.ebuild23
-rw-r--r--virtual/rust/rust-1.75.0-r1.ebuild23
-rw-r--r--virtual/rust/rust-1.76.0.ebuild23
-rw-r--r--virtual/rust/rust-1.77.1.ebuild23
-rw-r--r--virtual/rust/rust-1.78.0.ebuild23
13 files changed, 206 insertions, 65 deletions
diff --git a/virtual/rust/metadata.xml b/virtual/rust/metadata.xml
index 85cf4eb92057..c417957ed3fb 100644
--- a/virtual/rust/metadata.xml
+++ b/virtual/rust/metadata.xml
@@ -1,8 +1,25 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>rust@gentoo.org</email>
- <name>Rust Project</name>
- </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>randy@electronsweatshop.com</email>
+ <name>Randy Barlow</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>navi@vlhl.dev</email>
+ <name>Anna Figueiredo Gomes</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>matoro_gentoo@matoro.tk</email>
+ <name>Matoro Mahri</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>rust@gentoo.org</email>
+ <name>Rust Project</name>
+ </maintainer>
+ <use>
+ <flag name="profiler">Build the profiler runtime and rust-demangler tool (needed for '-C profile-generate' or '-C instrument-coverage' codegen opts)</flag>
+ <flag name="rustfmt">Install rustfmt, Rust code formatter</flag>
+ </use>
+ <stabilize-allarches/>
</pkgmetadata>
diff --git a/virtual/rust/rust-1.34.2.ebuild b/virtual/rust/rust-1.34.2.ebuild
deleted file mode 100644
index 2294f68c0624..000000000000
--- a/virtual/rust/rust-1.34.2.ebuild
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Virtual for Rust language compiler"
-HOMEPAGE=""
-SRC_URI=""
-
-LICENSE=""
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-
-BDEPEND=""
-RDEPEND="|| ( =dev-lang/rust-${PV}* =dev-lang/rust-bin-${PV}* )"
diff --git a/virtual/rust/rust-1.35.0.ebuild b/virtual/rust/rust-1.35.0.ebuild
deleted file mode 100644
index 1ba2f337c1e9..000000000000
--- a/virtual/rust/rust-1.35.0.ebuild
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Virtual for Rust language compiler"
-HOMEPAGE=""
-SRC_URI=""
-
-LICENSE=""
-SLOT="0"
-KEYWORDS="~amd64 arm64 ~ppc64 ~x86"
-
-BDEPEND=""
-RDEPEND="|| ( =dev-lang/rust-${PV}* =dev-lang/rust-bin-${PV}* )"
diff --git a/virtual/rust/rust-1.36.0.ebuild b/virtual/rust/rust-1.36.0.ebuild
deleted file mode 100644
index 75f822399482..000000000000
--- a/virtual/rust/rust-1.36.0.ebuild
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Virtual for Rust language compiler"
-HOMEPAGE=""
-SRC_URI=""
-
-LICENSE=""
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-
-BDEPEND=""
-RDEPEND="|| ( =dev-lang/rust-${PV}* =dev-lang/rust-bin-${PV}* )"
diff --git a/virtual/rust/rust-1.37.0.ebuild b/virtual/rust/rust-1.37.0.ebuild
deleted file mode 100644
index 75f822399482..000000000000
--- a/virtual/rust/rust-1.37.0.ebuild
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Virtual for Rust language compiler"
-HOMEPAGE=""
-SRC_URI=""
-
-LICENSE=""
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-
-BDEPEND=""
-RDEPEND="|| ( =dev-lang/rust-${PV}* =dev-lang/rust-bin-${PV}* )"
diff --git a/virtual/rust/rust-1.71.0-r2.ebuild b/virtual/rust/rust-1.71.0-r2.ebuild
new file mode 100644
index 000000000000..f452208a1d82
--- /dev/null
+++ b/virtual/rust/rust-1.71.0-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-16"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="profiler rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
+)"
diff --git a/virtual/rust/rust-1.71.1-r2.ebuild b/virtual/rust/rust-1.71.1-r2.ebuild
new file mode 100644
index 000000000000..62393a5d36f6
--- /dev/null
+++ b/virtual/rust/rust-1.71.1-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-16"
+KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="profiler rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
+)"
diff --git a/virtual/rust/rust-1.73.0-r1.ebuild b/virtual/rust/rust-1.73.0-r1.ebuild
new file mode 100644
index 000000000000..36a81c55f875
--- /dev/null
+++ b/virtual/rust/rust-1.73.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-17"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="profiler rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
+)"
diff --git a/virtual/rust/rust-1.74.1-r1.ebuild b/virtual/rust/rust-1.74.1-r1.ebuild
new file mode 100644
index 000000000000..4e9f43e5561b
--- /dev/null
+++ b/virtual/rust/rust-1.74.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-17"
+KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="profiler rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
+)"
diff --git a/virtual/rust/rust-1.75.0-r1.ebuild b/virtual/rust/rust-1.75.0-r1.ebuild
new file mode 100644
index 000000000000..4e9f43e5561b
--- /dev/null
+++ b/virtual/rust/rust-1.75.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-17"
+KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="profiler rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
+)"
diff --git a/virtual/rust/rust-1.76.0.ebuild b/virtual/rust/rust-1.76.0.ebuild
new file mode 100644
index 000000000000..2790ab8f7afc
--- /dev/null
+++ b/virtual/rust/rust-1.76.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-17"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="profiler rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]
+)"
diff --git a/virtual/rust/rust-1.77.1.ebuild b/virtual/rust/rust-1.77.1.ebuild
new file mode 100644
index 000000000000..516aad0fc87d
--- /dev/null
+++ b/virtual/rust/rust-1.77.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-17"
+KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="rustfmt profiler"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]
+)"
diff --git a/virtual/rust/rust-1.78.0.ebuild b/virtual/rust/rust-1.78.0.ebuild
new file mode 100644
index 000000000000..89d91522025f
--- /dev/null
+++ b/virtual/rust/rust-1.78.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-18"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt profiler"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]
+)"