summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual')
-rw-r--r--virtual/python-asyncio/metadata.xml5
-rw-r--r--virtual/python-asyncio/python-asyncio-0.ebuild23
2 files changed, 28 insertions, 0 deletions
diff --git a/virtual/python-asyncio/metadata.xml b/virtual/python-asyncio/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/virtual/python-asyncio/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/virtual/python-asyncio/python-asyncio-0.ebuild b/virtual/python-asyncio/python-asyncio-0.ebuild
new file mode 100644
index 000000000000..b716210e5d84
--- /dev/null
+++ b/virtual/python-asyncio/python-asyncio-0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{3,4,5} )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for the Python 3.4+ asyncio module"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/asyncio[${PYTHON_USEDEP}]' python3_3)"