summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/baikal')
-rw-r--r--www-apps/baikal/Manifest2
-rw-r--r--www-apps/baikal/baikal-0.2.4.ebuild52
-rw-r--r--www-apps/baikal/baikal-0.2.7.ebuild56
-rw-r--r--www-apps/baikal/files/postinstall-en.txt4
-rw-r--r--www-apps/baikal/metadata.xml8
5 files changed, 122 insertions, 0 deletions
diff --git a/www-apps/baikal/Manifest b/www-apps/baikal/Manifest
new file mode 100644
index 000000000000..a02314e8d2a3
--- /dev/null
+++ b/www-apps/baikal/Manifest
@@ -0,0 +1,2 @@
+DIST baikal-regular-0.2.4.tgz 868606 SHA256 5a8a57323d3662e167c8b45b5d10748139be94f54d4cc440aca8aff0159f9678 SHA512 84ac92a9fc0da108a7a56972a6ec4f08bdd5223c4052589db2cbe030093eeb250e5df769a02cd86b74e92c6c56601e1df1f1d422e3a9bc1fc958931f93a0d6ba WHIRLPOOL 010f4da3c1bb3cf08c1567f80843c44877f2a46a2d0a86258cb903bfc9e7c08da7afeae69e93c524a178ebf2cb89ab35579485349e06e52619b34ca163e09b05
+DIST baikal-regular-0.2.7.tgz 2273699 SHA256 268daeec96b9f1bbfee0c16398ae213abfe827c97ec487179985828b6267359f SHA512 261e34eda6e85e38f9478e04f68fdea09ea12203a11b47aaf1a446e33333a9d8d1d9663f4a36da1cfd2adf776ba3f4be459b2639cc1a23e64e8584e47632bb8f WHIRLPOOL bf3e750c9cb5e9e372794e24516e8acb6d43abe1e76d30e3033994e617082f62bef87f5b33363937818ccb1ac35cd37d59dc7caab42356206be37967d284b8f0
diff --git a/www-apps/baikal/baikal-0.2.4.ebuild b/www-apps/baikal/baikal-0.2.4.ebuild
new file mode 100644
index 000000000000..7156c4a51038
--- /dev/null
+++ b/www-apps/baikal/baikal-0.2.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit webapp
+
+DESCRIPTION="Lightweight CalDAV+CardDAV server"
+HOMEPAGE="http://baikal-server.com/"
+SRC_URI="http://baikal-server.com/get/${PN}-regular-${PV}.tgz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64"
+IUSE="+mysql sqlite"
+REQUIRED_USE="|| ( mysql sqlite )"
+
+RDEPEND=">=dev-lang/php-5.3[pdo,xml,mysql?,sqlite?]
+ mysql? ( virtual/mysql )
+ sqlite? ( dev-db/sqlite )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}-regular
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc *.md || die "dodoc failed"
+
+ einfo "Installing web files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r html/* html/.htaccess Core || die "doins failed"
+
+ einfo "Setting up container for configuration"
+ insinto /etc/${PN}
+ doins Specific/.htaccess || die "doins failed"
+
+ einfo "Fixing symlinks"
+ local link target
+ find "${D}${MY_HTDOCSDIR}" -type l | while read link ; do
+ target=$(readlink "${link}")
+ target=${target/..\/Core/Core}
+ rm "${link}" && ln -s "${target}" "${link}"
+ done
+ dosym /etc/${PN} "${MY_HTDOCSDIR}"/Specific
+ dosym . "${MY_HTDOCSDIR}"/html
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ webapp_src_install
+
+ fowners -R apache:apache /etc/${PN}
+}
diff --git a/www-apps/baikal/baikal-0.2.7.ebuild b/www-apps/baikal/baikal-0.2.7.ebuild
new file mode 100644
index 000000000000..e2738a285bbe
--- /dev/null
+++ b/www-apps/baikal/baikal-0.2.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit webapp
+
+DESCRIPTION="Lightweight CalDAV+CardDAV server"
+HOMEPAGE="http://baikal-server.com/"
+SRC_URI="http://baikal-server.com/get/${PN}-regular-${PV}.tgz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64"
+IUSE="+mysql sqlite"
+REQUIRED_USE="|| ( mysql sqlite )"
+
+RDEPEND=">=dev-lang/php-5.3[ctype,filter,pdo,session,xml,mysql?,sqlite?]
+ mysql? ( virtual/mysql )
+ sqlite? ( dev-db/sqlite )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}-regular
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc *.md || die "dodoc failed"
+
+ einfo "Installing web files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r html/* html/.htaccess Core vendor || die "doins failed"
+
+ einfo "Setting up container for configuration"
+ insinto /etc/${PN}
+ doins Specific/.htaccess || die "doins failed"
+
+ einfo "Fixing symlinks"
+ local link target
+ find "${D}${MY_HTDOCSDIR}" -type l | while read link ; do
+ target=$(readlink "${link}")
+ target=${target/..\/Core/Core}
+ rm "${link}" && ln -s "${target}" "${link}"
+ done
+ dosym /etc/${PN} "${MY_HTDOCSDIR}"/Specific
+ dosym . "${MY_HTDOCSDIR}"/html
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ webapp_src_install
+
+ if has_version www-servers/apache ; then
+ fowners -R apache:apache /etc/${PN}
+ else
+ einfo "/etc/${PN} must be owned by the webserver user for baikal"
+ fi
+}
diff --git a/www-apps/baikal/files/postinstall-en.txt b/www-apps/baikal/files/postinstall-en.txt
new file mode 100644
index 000000000000..aafca857472d
--- /dev/null
+++ b/www-apps/baikal/files/postinstall-en.txt
@@ -0,0 +1,4 @@
+In order to setup baïkal:
+- create /etc/${PN}/ENABLE_INSTALL owner apache:apache
+- point your browser at the instal's URL and follow the setup
+To upgrade baïkal, you have to follow the setup instructions
diff --git a/www-apps/baikal/metadata.xml b/www-apps/baikal/metadata.xml
new file mode 100644
index 000000000000..263de02a5e77
--- /dev/null
+++ b/www-apps/baikal/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>grobian@gentoo.org</email>
+ <name>Fabian Groffen</name>
+ </maintainer>
+</pkgmetadata>