summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/blazeblogger/blazeblogger-1.2.0-r1.ebuild')
-rw-r--r--www-apps/blazeblogger/blazeblogger-1.2.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/www-apps/blazeblogger/blazeblogger-1.2.0-r1.ebuild b/www-apps/blazeblogger/blazeblogger-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..d141fe2920d7
--- /dev/null
+++ b/www-apps/blazeblogger/blazeblogger-1.2.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="simple-to-use, capable content management system for the cmdline producing static content"
+HOMEPAGE="http://blaze.blackened.cz/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz
+ doc? ( http://${PN}.googlecode.com/files/${PN}-doc-${PV}.tar.gz ) "
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e '/-m 644 COPYING/d' \
+ -e '/-m 644 INSTALL/d' \
+ -i Makefile || die
+
+ epatch "${FILESDIR}"/${P}-bash-completion.patch #bug 417953
+}
+
+src_install() {
+ emake prefix="${D}/usr" config="${D}/etc" \
+ compdir="${D}/usr/share/bash-completion" install
+
+ use doc && dohtml -r "${WORKDIR}"/${PN}-doc-${PV}/*
+}