summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/jekyll-watch/jekyll-watch-1.5.1.ebuild')
-rw-r--r--www-apps/jekyll-watch/jekyll-watch-1.5.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/www-apps/jekyll-watch/jekyll-watch-1.5.1.ebuild b/www-apps/jekyll-watch/jekyll-watch-1.5.1.ebuild
new file mode 100644
index 000000000000..d6319e7d00b6
--- /dev/null
+++ b/www-apps/jekyll-watch/jekyll-watch-1.5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md History.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rebuild your Jekyll site when a file changes with the --watch switch"
+HOMEPAGE="https://github.com/jekyll/jekyll-watch"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/listen-3.0"
+ruby_add_bdepend "test? ( >=www-apps/jekyll-2 )"
+
+all_ruby_prepare() {
+ rm Rakefile || die
+}