summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/mythweb')
-rw-r--r--www-apps/mythweb/Manifest3
-rw-r--r--www-apps/mythweb/files/0.25-postinstall-en.txt9
-rw-r--r--www-apps/mythweb/files/mythweb.conf.nginx30
-rw-r--r--www-apps/mythweb/files/reconfig39
-rw-r--r--www-apps/mythweb/metadata.xml13
-rw-r--r--www-apps/mythweb/mythweb-0.26.0.ebuild90
-rw-r--r--www-apps/mythweb/mythweb-0.27.1.ebuild90
-rw-r--r--www-apps/mythweb/mythweb-0.27.ebuild90
8 files changed, 364 insertions, 0 deletions
diff --git a/www-apps/mythweb/Manifest b/www-apps/mythweb/Manifest
new file mode 100644
index 000000000000..87e72a94df54
--- /dev/null
+++ b/www-apps/mythweb/Manifest
@@ -0,0 +1,3 @@
+DIST mythplugins-0.26.0.tar.bz2 36673620 SHA256 4e7f0493f37792c084c1b4d0b5863b4201ebce6d62ab7c6cc31ca74087d83c62 SHA512 51c10f46186e14e69c5626f2ae0955692c71aa7459fd018efaab1b99809cad533a84754d53455017102ff6f94cc9905dc303248a29d4095ba8f4f685bb022f49 WHIRLPOOL a2b995f2a94a2eb22fa0740dd840a2fe2d9d4b808af1dc43e9d83c626d93ed95134d64db2049e4b79379838ae16b1de6547b56277531e2752e6779b3cddbf25a
+DIST mythweb-0.27.1.tar.gz 1686541 SHA256 2758cfe9e0fcef71fec2d7deb9ea5fdd54daa21832da9c56d124659e74a19adc SHA512 6f92b5c0858b8451be3cce48188e04cd987224a16c0b5cb94872fb165ec0e3e5e4aa4f8ba18220e9401c48ddbc36c28a04cc8ebaf819e1340f6eb5133f3bcc69 WHIRLPOOL ea702d678c7cf2f4828dc2666a2dfa93ccdff2a2a2ee15fb4d3fddd857b4c406fca26b478e6531f6a7a2faa7c47520674eb96964364012d99447b4658ddc5d2f
+DIST mythweb-0.27.tar.gz 1686502 SHA256 7e54d6b388e2e8f3e50515c3fe46113f4217e3989242459a0fa73c928dcca494 SHA512 d166cd764730d844e844b5ba780b5635be6d2329d2051a382ab79579334e51fbfa0e73683e30c312d7618e84c7e63f868d32d5449d0804ff01dc0a592a60d9d1 WHIRLPOOL a2ad85234c2e9e2e6f370355becfca173a672afcb5c7d919fb046ab1a5e735683b96e3b6d36a2c83986116c568f878728988e78a1f27bd1861cd400a999b186a
diff --git a/www-apps/mythweb/files/0.25-postinstall-en.txt b/www-apps/mythweb/files/0.25-postinstall-en.txt
new file mode 100644
index 000000000000..0848d60cfa0f
--- /dev/null
+++ b/www-apps/mythweb/files/0.25-postinstall-en.txt
@@ -0,0 +1,9 @@
+You probably want to modify
+${VHOST_CONFDIR}/mythweb.include
+to fit your needs and load it into your web server
+configuration.
+
+In order to prevent unauthorized access to your MythTV
+installation, MythWeb can be configured to require
+authentication using htdigest or htpasswd. See
+${VHOST_CONFDIR}/mythweb.include for more info.
diff --git a/www-apps/mythweb/files/mythweb.conf.nginx b/www-apps/mythweb/files/mythweb.conf.nginx
new file mode 100644
index 000000000000..2737de91c931
--- /dev/null
+++ b/www-apps/mythweb/files/mythweb.conf.nginx
@@ -0,0 +1,30 @@
+location /mythweb/ {
+ root VHOST_HTDOCS;
+ auth_basic "MythWeb";
+ auth_basic_user_file /var/www/htpasswd;
+ index VHOST_APPDIR/mythweb.php;
+ try_files $uri @handler;
+}
+
+location ~ /mythweb/.+\.php {
+ root VHOST_HTDOCS;
+ include fastcgi_params;
+ fastcgi_index mythweb.php;
+ fastcgi_split_path_info ^(.+\.php)(/?.+)$;
+ fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
+ fastcgi_param PATH_INFO $fastcgi_path_info;
+ fastcgi_param db_server localhost;
+ fastcgi_param db_name mythconverg;
+ fastcgi_param db_login mythtv;
+ fastcgi_param db_password mythtv;
+ fastcgi_param hostname mythtv.cardoe.com;
+ fastcgi_pass 127.0.0.1:9000;
+}
+
+location @handler {
+ root VHOST_HTDOCS;
+ rewrite VHOST_APPDIR/(.+\.(php|pl))/.* VHOST_APPDIR/$1 last;
+ rewrite VHOST_APPDIR/(pl(/.*)?)$ VHOST_APPDIR/mythweb.pl/$1 last;
+ rewrite VHOST_APPDIR/(.+)$ VHOST_APPDIR/mythweb.php/$1 last;
+ rewrite VHOST_APPDIR/(.*)$ VHOST_APPDIR/mythweb.php last;
+}
diff --git a/www-apps/mythweb/files/reconfig b/www-apps/mythweb/files/reconfig
new file mode 100644
index 000000000000..01ab9aacff7a
--- /dev/null
+++ b/www-apps/mythweb/files/reconfig
@@ -0,0 +1,39 @@
+#!/bin/bash
+
+die() {
+ echo "###"
+ echo $1
+ echo "###"
+ exit 1
+}
+
+if [[ $1 = "install" ]]; then
+
+ if [[ "${VHOST_SERVER}" = "apache" ]]; then
+ sed -e "s|/var/www/html/data|${MY_INSTALLDIR}/data|g" \
+ -e "s|/var/www/html|${MY_INSTALLDIR}|g" \
+ ${MY_SERVERCONFIGDIR}/${VHOST_SERVER}-mythweb.conf > \
+ ${VHOST_CONFDIR}/mythweb.include || \
+ die "apache sed failed"
+ elif [[ "${VHOST_SERVER}" = "lighttpd" ]]; then
+ sed -e "s|/var/www/localhost/htdocs/mythweb|${MY_INSTALLDIR}|g" \
+ ${MY_SERVERCONFIGDIR}/${VHOST_SERVER}-mythweb.conf > \
+ ${VHOST_CONFDIR}/mythweb.include || \
+ die "lighttpd sed failed"
+ elif [[ "${VHOST_SERVER}" = "nginx" ]]; then
+ sed -e "s|VHOST_HTDOCS|${VHOST_HTDOCSDIR}|g" \
+ -e "s|VHOST_APPDIR|${VHOST_APPDIR}|g" \
+ ${MY_SERVERCONFIGDIR}/${VHOST_SERVER}-mythweb.include > \
+ ${VHOST_CONFDIR}/mythweb.include || \
+ die "nginx sed failed"
+ fi
+
+ # Ownership fixes
+ chown ${VHOST_SERVER_UID}:${VHOST_SERVER_GID} "${MY_INSTALLDIR}"/data || \
+ die "chown failed"
+
+elif [[ $1 = "clean" ]]; then
+ echo $1
+fi
+
+exit 0
diff --git a/www-apps/mythweb/metadata.xml b/www-apps/mythweb/metadata.xml
new file mode 100644
index 000000000000..bbe97fab0a78
--- /dev/null
+++ b/www-apps/mythweb/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mythtv</herd>
+ <herd>web-apps</herd>
+ <maintainer>
+ <email>cardoe@gentoo.org</email>
+ <description>Do not CC me on bugs</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">MythTV/mythweb</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apps/mythweb/mythweb-0.26.0.ebuild b/www-apps/mythweb/mythweb-0.26.0.ebuild
new file mode 100644
index 000000000000..3caefcebf3bf
--- /dev/null
+++ b/www-apps/mythweb/mythweb-0.26.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils webapp
+
+#BACKPORTS="4f6ac2a60b"
+# Release version
+MY_PV="${PV%_p*}"
+MY_P="mythplugins-${MY_PV}"
+
+DESCRIPTION="PHP scripts intended to manage MythTV from a web browser"
+HOMEPAGE="http://www.mythtv.org"
+LICENSE="GPL-2"
+SRC_URI="ftp://ftp.osuosl.org/pub/mythtv/${MY_P}.tar.bz2
+ ${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${MY_P}-${BACKPORTS}.tar.xz}"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-lang/php[json,mysql,session,posix]
+ virtual/httpd-php
+ dev-perl/DBI
+ dev-perl/DBD-mysql
+ dev-perl/HTTP-Date
+ dev-perl/Net-UPnP"
+
+DEPEND="${RDEPEND}"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${MY_P}/${PN}"
+
+src_prepare() {
+ cd "${S}"/../
+
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/../patches" \
+ epatch
+
+ epatch_user
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # Install docs
+ cd "${S}"
+ dodoc README INSTALL
+
+ # Install htdocs files
+ insinto "${MY_HTDOCSDIR}"
+ doins mythweb.php
+ doins -r classes
+ doins -r configuration
+ doins -r data
+ doins -r includes
+ doins -r js
+ doins -r modules
+ doins -r skins
+ doins -r tests
+ exeinto "${MY_HTDOCSDIR}"
+ doexe mythweb.pl
+
+ # Install our server config files
+ webapp_server_configfile apache mythweb.conf.apache mythweb.conf
+ webapp_server_configfile lighttpd mythweb.conf.lighttpd mythweb.conf
+ webapp_server_configfile nginx "${FILESDIR}"/mythweb.conf.nginx \
+ mythweb.include
+
+ # Data needs to be writable and modifiable by the web server
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+
+ # Message to display after install
+ webapp_postinst_txt en "${FILESDIR}"/0.25-postinstall-en.txt
+
+ # Script to set the correct defaults on install
+ webapp_hook_script "${FILESDIR}"/reconfig
+
+ webapp_src_install
+}
diff --git a/www-apps/mythweb/mythweb-0.27.1.ebuild b/www-apps/mythweb/mythweb-0.27.1.ebuild
new file mode 100644
index 000000000000..ebd589327833
--- /dev/null
+++ b/www-apps/mythweb/mythweb-0.27.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils webapp
+
+#BACKPORTS="4f6ac2a60b"
+# Release version
+MY_PV="${PV%_p*}"
+MY_P="mythweb-${MY_PV}"
+
+DESCRIPTION="PHP scripts intended to manage MythTV from a web browser"
+HOMEPAGE="http://www.mythtv.org"
+LICENSE="GPL-2"
+SRC_URI="https://github.com/MythTV/mythweb/archive/v${MY_PV}.tar.gz -> mythweb-${MY_PV}.tar.gz
+ ${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${MY_P}-${BACKPORTS}.tar.xz}"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-lang/php[json,mysql,session,posix]
+ virtual/httpd-php
+ dev-perl/DBI
+ dev-perl/DBD-mysql
+ dev-perl/HTTP-Date
+ dev-perl/Net-UPnP"
+
+DEPEND="${RDEPEND}"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cd "${S}"/../
+
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/../patches" \
+ epatch
+
+ epatch_user
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # Install docs
+ cd "${S}"
+ dodoc README INSTALL
+
+ # Install htdocs files
+ insinto "${MY_HTDOCSDIR}"
+ doins mythweb.php
+ doins -r classes
+ doins -r configuration
+ doins -r data
+ doins -r includes
+ doins -r js
+ doins -r modules
+ doins -r skins
+ doins -r tests
+ exeinto "${MY_HTDOCSDIR}"
+ doexe mythweb.pl
+
+ # Install our server config files
+ webapp_server_configfile apache mythweb.conf.apache mythweb.conf
+ webapp_server_configfile lighttpd mythweb.conf.lighttpd mythweb.conf
+ webapp_server_configfile nginx "${FILESDIR}"/mythweb.conf.nginx \
+ mythweb.include
+
+ # Data needs to be writable and modifiable by the web server
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+
+ # Message to display after install
+ webapp_postinst_txt en "${FILESDIR}"/0.25-postinstall-en.txt
+
+ # Script to set the correct defaults on install
+ webapp_hook_script "${FILESDIR}"/reconfig
+
+ webapp_src_install
+}
diff --git a/www-apps/mythweb/mythweb-0.27.ebuild b/www-apps/mythweb/mythweb-0.27.ebuild
new file mode 100644
index 000000000000..ebd589327833
--- /dev/null
+++ b/www-apps/mythweb/mythweb-0.27.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils webapp
+
+#BACKPORTS="4f6ac2a60b"
+# Release version
+MY_PV="${PV%_p*}"
+MY_P="mythweb-${MY_PV}"
+
+DESCRIPTION="PHP scripts intended to manage MythTV from a web browser"
+HOMEPAGE="http://www.mythtv.org"
+LICENSE="GPL-2"
+SRC_URI="https://github.com/MythTV/mythweb/archive/v${MY_PV}.tar.gz -> mythweb-${MY_PV}.tar.gz
+ ${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${MY_P}-${BACKPORTS}.tar.xz}"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-lang/php[json,mysql,session,posix]
+ virtual/httpd-php
+ dev-perl/DBI
+ dev-perl/DBD-mysql
+ dev-perl/HTTP-Date
+ dev-perl/Net-UPnP"
+
+DEPEND="${RDEPEND}"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cd "${S}"/../
+
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/../patches" \
+ epatch
+
+ epatch_user
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # Install docs
+ cd "${S}"
+ dodoc README INSTALL
+
+ # Install htdocs files
+ insinto "${MY_HTDOCSDIR}"
+ doins mythweb.php
+ doins -r classes
+ doins -r configuration
+ doins -r data
+ doins -r includes
+ doins -r js
+ doins -r modules
+ doins -r skins
+ doins -r tests
+ exeinto "${MY_HTDOCSDIR}"
+ doexe mythweb.pl
+
+ # Install our server config files
+ webapp_server_configfile apache mythweb.conf.apache mythweb.conf
+ webapp_server_configfile lighttpd mythweb.conf.lighttpd mythweb.conf
+ webapp_server_configfile nginx "${FILESDIR}"/mythweb.conf.nginx \
+ mythweb.include
+
+ # Data needs to be writable and modifiable by the web server
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+
+ # Message to display after install
+ webapp_postinst_txt en "${FILESDIR}"/0.25-postinstall-en.txt
+
+ # Script to set the correct defaults on install
+ webapp_hook_script "${FILESDIR}"/reconfig
+
+ webapp_src_install
+}