summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/drupal/Manifest3
-rw-r--r--www-apps/drupal/drupal-7.64.ebuild74
-rw-r--r--www-apps/drupal/drupal-8.5.11.ebuild84
-rw-r--r--www-apps/drupal/drupal-8.6.10.ebuild84
4 files changed, 0 insertions, 245 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 8d75d01dff48..a934dec7d03d 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,6 +1,3 @@
-DIST drupal-7.64.tar.gz 3297822 BLAKE2B 8f1e9fa72086ae41a4d5bc2b261d23b5302400263cea28eb4e7b70ffb56d16c70dde31f7759eec9493a485e4527ba6e1085321362e835110d9b672bb520331dd SHA512 90d4b863df5597ac7e88dc09317e3ab8b2beacd6051ef267de52d1fe599a8704f25ede708d2a106c18d76f19c2c9de1e5003086ab9116bae5624acd418e8a014
DIST drupal-7.65.tar.gz 3298607 BLAKE2B f3a728c3e464b8d94719ed7a79359c5fa2b8b0216ee90029d05e873377566a398d80f188f9dc36f2504057c0000a7bcd364d5c4f50652f25e73e1aa0e7d5d7b1 SHA512 a79ff93e13456b35160ee17f986dce9cffefa265d0034dab6223a3097eaf45c11ea3548904ff6c125be0817dc71a8ac7320aca91a11eefeaad03d45527725e79
-DIST drupal-8.5.11.tar.gz 15817672 BLAKE2B da944b432cacf070f47c3c16966c0a0a8950258f067bf2da50ae00281cee6a72f53940ad227ca2864f342c25a7bd6a500140f8070c932aa1a07a96b98016f1ff SHA512 16695af590d048882fa2c3b4aae071d6cbbad6eb4d0dd02763b7c95c782ef4cec70e3825cebbaecf2d5a6f18e2744017accb7bf9e7caf17b1b497eabfef3a348
DIST drupal-8.5.14.tar.gz 15828327 BLAKE2B aa638ac4643541d9ec2b2168633c8ab4fe6b64f3c2b9fec46a6a45903ccaaa26ba671c62d57c51a5698ad2558c6ed3ee491dff739f1eed05ea2a0fefba5ace31 SHA512 2be4878cbb27389d11f3686fdc911468a8481d7cbade168c70e733615f2ed699bcc8eb1798079d0b354c81caec0cf74fb232b310e9ab7e059c00fba4b3ee2796
-DIST drupal-8.6.10.tar.gz 16858107 BLAKE2B 1a86d907fea4ec77d88bc7a8d937baa093972b4823e347ce151040a8f7a53330433cea73273097a8960c41b9655094451f38160bcf2f6197fa7e7fcf82c52060 SHA512 acd37fd87a15ca5056b1b1341cd24481073b21dca279536f4065c817230b83dd41a01fc82867781ee2d70cd7e5ccd333b6bdda0cfe4966ce79bf5b1435ad5192
DIST drupal-8.6.13.tar.gz 17137449 BLAKE2B f52b082bdccbeb3600da723483bbdef8645babc84a433c82e38b7029332764361a3ca6996b6ac9c20e96c27b4412c7d14a9b0b454c234594f13ba4fdeba39029 SHA512 ed9da8596ca5f4dee569b2beea561b75742aa801ef450258786c6d496e9205cd865af3a6cca56bc276df48841b95bcaaaae46ffcda6bbf8183866ec3c991fff2
diff --git a/www-apps/drupal/drupal-7.64.ebuild b/www-apps/drupal/drupal-7.64.ebuild
deleted file mode 100644
index 2d1f90ebbd06..000000000000
--- a/www-apps/drupal/drupal-7.64.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit webapp
-
-MY_PV=${PV:0:3}.0
-
-DESCRIPTION="PHP-based open-source platform and content management system"
-HOMEPAGE="https://www.drupal.org/"
-SRC_URI="https://ftp.drupal.org/files/projects/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~ppc ~x86"
-IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
-
-RDEPEND="
- dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
- virtual/httpd-php
- accelerator? ( ||
- (
- dev-php/xcache
- (
- >=dev-lang/php-5.5[opcache]
- dev-php/pecl-apcu
- )
- )
- )
- uploadprogress? ( dev-php/pecl-uploadprogress )
- mysql? (
- || (
- dev-lang/php[mysql]
- dev-lang/php[mysqli]
- )
- )
- sqlite? ( dev-lang/php[sqlite] )
-"
-
-need_httpd_cgi
-
-REQUIRED_USE="|| ( mysql postgres sqlite )"
-
-src_install() {
- webapp_src_preinst
-
- local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt INSTALL.sqlite.txt UPGRADE.txt "
- dodoc ${docs}
- rm -f ${docs} INSTALL COPYRIGHT.txt || die
-
- cp sites/default/{default.settings.php,settings.php} || die
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- dodir "${MY_HTDOCSDIR}"/files
- webapp_serverowned "${MY_HTDOCSDIR}"/files
- webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
- webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
-
- webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
- webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
-
- webapp_src_install
-}
-
-pkg_postinst() {
- echo
- ewarn "SECURITY NOTICE"
- ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
- ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
- echo
-}
diff --git a/www-apps/drupal/drupal-8.5.11.ebuild b/www-apps/drupal/drupal-8.5.11.ebuild
deleted file mode 100644
index a8514d07dfe0..000000000000
--- a/www-apps/drupal/drupal-8.5.11.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit webapp
-
-MY_PV=${PV:0:3}.0
-MY_P=${P/_/-}
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="PHP-based open-source platform and content management system"
-HOMEPAGE="https://www.drupal.org/"
-SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~ppc ~x86"
-IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
-
-RDEPEND="
- dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
- virtual/httpd-php
- accelerator? ( ||
- (
- dev-php/xcache
- (
- >=dev-lang/php-5.5[opcache]
- dev-php/pecl-apcu
- )
- )
- )
- uploadprogress? ( dev-php/pecl-uploadprogress )
- mysql? (
- || (
- dev-lang/php[mysql]
- dev-lang/php[mysqli]
- )
- )
- sqlite? ( dev-lang/php[sqlite] )
-"
-
-need_httpd_cgi
-
-REQUIRED_USE="|| ( mysql postgres sqlite )"
-
-src_install() {
- webapp_src_preinst
-
- local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
- core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
-
- dodoc ${docs}
- rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
-
- cp sites/default/{default.settings.php,settings.php} || die
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- dodir "${MY_HTDOCSDIR}"/files
- webapp_serverowned "${MY_HTDOCSDIR}"/files
-
- webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
- webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
-
- webapp_src_install
-}
-
-pkg_postinst() {
- echo
- ewarn "SECURITY NOTICE"
- ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
- ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
- echo
- ewarn "If this is a new install, unless you want anyone with network access to your server to be"
- ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
- echo
- ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
- ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
- ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
- ewarn "reported by the setup."
- echo
-}
diff --git a/www-apps/drupal/drupal-8.6.10.ebuild b/www-apps/drupal/drupal-8.6.10.ebuild
deleted file mode 100644
index a8514d07dfe0..000000000000
--- a/www-apps/drupal/drupal-8.6.10.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit webapp
-
-MY_PV=${PV:0:3}.0
-MY_P=${P/_/-}
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="PHP-based open-source platform and content management system"
-HOMEPAGE="https://www.drupal.org/"
-SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~ppc ~x86"
-IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
-
-RDEPEND="
- dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
- virtual/httpd-php
- accelerator? ( ||
- (
- dev-php/xcache
- (
- >=dev-lang/php-5.5[opcache]
- dev-php/pecl-apcu
- )
- )
- )
- uploadprogress? ( dev-php/pecl-uploadprogress )
- mysql? (
- || (
- dev-lang/php[mysql]
- dev-lang/php[mysqli]
- )
- )
- sqlite? ( dev-lang/php[sqlite] )
-"
-
-need_httpd_cgi
-
-REQUIRED_USE="|| ( mysql postgres sqlite )"
-
-src_install() {
- webapp_src_preinst
-
- local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
- core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
-
- dodoc ${docs}
- rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
-
- cp sites/default/{default.settings.php,settings.php} || die
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- dodir "${MY_HTDOCSDIR}"/files
- webapp_serverowned "${MY_HTDOCSDIR}"/files
-
- webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
- webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
-
- webapp_src_install
-}
-
-pkg_postinst() {
- echo
- ewarn "SECURITY NOTICE"
- ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
- ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
- echo
- ewarn "If this is a new install, unless you want anyone with network access to your server to be"
- ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
- echo
- ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
- ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
- ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
- ewarn "reported by the setup."
- echo
-}