summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/chromium/chromium-70.0.3521.2.ebuild')
-rw-r--r--www-client/chromium/chromium-70.0.3521.2.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-70.0.3521.2.ebuild b/www-client/chromium/chromium-70.0.3521.2.ebuild
index 953d96e54e41..c70f37c2a62f 100644
--- a/www-client/chromium/chromium-70.0.3521.2.ebuild
+++ b/www-client/chromium/chromium-70.0.3521.2.ebuild
@@ -573,6 +573,18 @@ src_compile() {
#"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
+ # Build mksnapshot and pax-mark it.
+ local x
+ for x in mksnapshot v8_context_snapshot_generator; do
+ if tc-is-cross-compiler; then
+ eninja -C out/Release "host/${x}"
+ pax-mark m "out/Release/host/${x}"
+ else
+ eninja -C out/Release "${x}"
+ pax-mark m "out/Release/${x}"
+ fi
+ done
+
# Even though ninja autodetects number of CPUs, we respect
# user's options, for debugging with -j 1 or any other reason.
eninja -C out/Release chrome chromedriver