summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-65.0-r1.ebuild')
-rw-r--r--www-client/firefox/firefox-65.0-r1.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-65.0-r1.ebuild b/www-client/firefox/firefox-65.0-r1.ebuild
index 5fe43fe3beee..b1800c1eb71c 100644
--- a/www-client/firefox/firefox-65.0-r1.ebuild
+++ b/www-client/firefox/firefox-65.0-r1.ebuild
@@ -482,6 +482,12 @@ src_configure() {
# when they would normally be larger than 2GiB.
append-ldflags "-Wl,--compress-debug-sections=zlib"
+ if use clang ; then
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1482204
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1483822
+ mozconfig_annotate 'elf-hack is broken when using Clang' --disable-elf-hack
+ fi
+
echo "mk_add_options MOZ_OBJDIR=${BUILD_OBJ_DIR}" >> "${S}"/.mozconfig
echo "mk_add_options XARGS=/usr/bin/xargs" >> "${S}"/.mozconfig