summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-68.7.0.ebuild')
-rw-r--r--www-client/firefox/firefox-68.7.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/www-client/firefox/firefox-68.7.0.ebuild b/www-client/firefox/firefox-68.7.0.ebuild
index 035e41b50ae7..4e8dd7c4d524 100644
--- a/www-client/firefox/firefox-68.7.0.ebuild
+++ b/www-client/firefox/firefox-68.7.0.ebuild
@@ -42,7 +42,7 @@ LLVM_MAX_SLOT=10
inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils \
- autotools mozlinguas-v2 virtualx
+ autotools mozlinguas-v2 multiprocessing virtualx
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="https://www.mozilla.com/firefox"
@@ -303,6 +303,12 @@ src_prepare() {
# Allow user to apply any additional patches without modifing ebuild
eapply_user
+ # Make LTO respect MAKEOPTS
+ sed -i \
+ -e "s/multiprocessing.cpu_count()/$(makeopts_jobs)/" \
+ "${S}"/build/moz.configure/toolchain.configure \
+ || die "sed failed to set num_cores"
+
# Enable gnomebreakpad
if use debug ; then
sed -i -e "s:GNOME_DISABLE_CRASH_DIALOG=1:GNOME_DISABLE_CRASH_DIALOG=0:g" \