summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/qutebrowser/qutebrowser-1.6.0.ebuild')
-rw-r--r--www-client/qutebrowser/qutebrowser-1.6.0.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/www-client/qutebrowser/qutebrowser-1.6.0.ebuild b/www-client/qutebrowser/qutebrowser-1.6.0.ebuild
index 9870584a71be..a464d065fdc3 100644
--- a/www-client/qutebrowser/qutebrowser-1.6.0.ebuild
+++ b/www-client/qutebrowser/qutebrowser-1.6.0.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://www.qutebrowser.org/ https://github.com/qutebrowser/qutebrowse
LICENSE="GPL-3"
SLOT="0"
-IUSE="test"
+IUSE="scripts test"
COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${COMMON_DEPEND}
@@ -55,6 +55,17 @@ python_install_all() {
domenu misc/${PN}.desktop
doicon -s scalable icons/${PN}.svg
+ if use scripts; then
+ # Install only those userscripts that have an explicit license header
+ exeinto /usr/share/qutebrowser/userscripts/
+ doexe misc/userscripts/dmenu_qutebrowser
+ doexe misc/userscripts/openfeeds
+ doexe misc/userscripts/qute-keepass
+ doexe misc/userscripts/qute-pass
+ doexe misc/userscripts/rss
+ doexe misc/userscripts/tor_identity
+ fi
+
distutils-r1_python_install_all
}