summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/buku/Manifest1
-rw-r--r--www-misc/buku/buku-3.7.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/www-misc/buku/Manifest b/www-misc/buku/Manifest
index 07c7674eab12..2b805aaa24e7 100644
--- a/www-misc/buku/Manifest
+++ b/www-misc/buku/Manifest
@@ -1,2 +1,3 @@
DIST buku-3.5.tar.gz 93634 BLAKE2B 55c4b50b3bf8121c116554613768cd836080b363d702469eb2f76349c26d8d6246f73746248123030c5657006e09a9f72242354ce3af20d93b845f1870929bbc SHA512 b9f70665c83033ca030302e805ee051a524b2f0decae6c99ad54749b4a4bc91ae8261976018741361489525f359ea71c01ddb3e2d827ab9a052fb0acc98be8ed
DIST buku-3.6.tar.gz 92012 BLAKE2B a92f45810acfb11493ca4c0ff75c57b81064627dea632bdf55ab5e33618e2721163ba0dcaa95d8cbec579605bc714d24ef894de10f4a10f3bf6ef5eb5aa42cc3 SHA512 77fabec93e85d6b6d5dbc0a3c4d095f26093f1d86aadb2a3c961a3947ac1c59acac69c94f732d30daec9943728e35d5e08bede1f0448c02d2db9136fe426186f
+DIST buku-3.7.tar.gz 98970 BLAKE2B 7227b5fb632d9ec92ef236d1889f2ba0872d67d2c3cfb302beab48b03e8d62a762d02e517014d5041a9f79deab74d0f5ceca12c315eb77922f73d359b58a48b5 SHA512 c515e11686aa8888231ffc8c1d6ec29d6143f1714eacdf640d8d3d3fa3fd469e111073762a3ba831dd673d63034afe3db181ec66501c18165e8ddd97cbc57c82
diff --git a/www-misc/buku/buku-3.7.ebuild b/www-misc/buku/buku-3.7.ebuild
new file mode 100644
index 000000000000..ea918b0c806b
--- /dev/null
+++ b/www-misc/buku/buku-3.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Powerful command-line bookmark manager"
+HOMEPAGE="https://github.com/jarun/Buku"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.13.1[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/zsh/site-functions
+ doins auto-completion/zsh/_*
+
+ newbashcomp auto-completion/bash/buku-completion.bash "${PN}"
+
+ doman buku.1
+}
+
+python_test() {
+ py.test -v tests/test_* || die
+}