summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/pdfjs/pdfjs-2.14.305.ebuild')
-rw-r--r--www-plugins/pdfjs/pdfjs-2.14.305.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/www-plugins/pdfjs/pdfjs-2.14.305.ebuild b/www-plugins/pdfjs/pdfjs-2.14.305.ebuild
new file mode 100644
index 000000000000..463a0a0be25e
--- /dev/null
+++ b/www-plugins/pdfjs/pdfjs-2.14.305.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A PDF reader in JavaScript"
+HOMEPAGE="https://mozilla.github.io/pdf.js/"
+SRC_URI="https://github.com/mozilla/pdf.js/releases/download/v${PV}/${P}-dist.zip -> ${P}.zip"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+src_install() {
+ insinto /usr/share/pdf.js/
+
+ doins -r build
+ doins -r web
+}