summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/gunicorn/gunicorn-20.0.4.ebuild')
-rw-r--r--www-servers/gunicorn/gunicorn-20.0.4.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/www-servers/gunicorn/gunicorn-20.0.4.ebuild b/www-servers/gunicorn/gunicorn-20.0.4.ebuild
deleted file mode 100644
index 574c5c88899e..000000000000
--- a/www-servers/gunicorn/gunicorn-20.0.4.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A WSGI HTTP Server for UNIX"
-HOMEPAGE="https://gunicorn.org https://pypi.org/project/gunicorn https://github.com/benoitc/gunicorn"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT PSF-2 doc? ( BSD )"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~x64-macos"
-
-RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
-
-DOCS="README.rst"
-
-distutils_enable_sphinx 'docs/source' --no-autodoc
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -e 's:--cov=gunicorn --cov-report=xml::' -i setup.cfg || die
- distutils-r1_src_prepare
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/source/_build/html/. )
-
- distutils-r1_python_install_all
-}