summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/tornado/Manifest2
-rw-r--r--www-servers/tornado/files/drop-intersphinx.patch36
-rw-r--r--www-servers/tornado/files/tornado-4.2.1-py3.5-backport.patch63
-rw-r--r--www-servers/tornado/tornado-4.2.1.ebuild68
-rw-r--r--www-servers/tornado/tornado-4.3.ebuild67
5 files changed, 0 insertions, 236 deletions
diff --git a/www-servers/tornado/Manifest b/www-servers/tornado/Manifest
index 8d0dfa267539..66fca8816cef 100644
--- a/www-servers/tornado/Manifest
+++ b/www-servers/tornado/Manifest
@@ -1,3 +1 @@
-DIST tornado-4.2.1.tar.gz 434304 SHA256 a16fcdc4f76b184cb82f4f9eaeeacef6113b524b26a2cb331222e4a7fa6f2969 SHA512 5bb391b05c8574c8ae5e315b7617e1259ab80e993f1230db611c5beef8058517cc588daf75fac2e0f7969668715470b06ed183c9832b22081be265beb6967e30 WHIRLPOOL 5230055b1d10c32968c1f400e3d1fffbde1cbf9b4578ec42835cb202234d24daf6d4e621622a2fc884d3db8e5b3f64d6e62d17841bb9d71ab8ab91928cd0dfe3
-DIST tornado-4.3.tar.gz 450916 SHA256 c9c2d32593d16eedf2cec1b6a41893626a2649b40b21ca9c4cac4243bde2efbf SHA512 4220ae67eb8bfbe112edead47f37308eca9a272df24f073a7e5d1a0d0e90fb9f8c74b48db0d78fd995463591924800ab5268d32bcacc497ba204f164bce438bc WHIRLPOOL 13dec91628a7941623d0e8d381aa893ec6e4f1a480171bb29263c85cb11449d650488f459705c0b5d7b2d37044628caec6f14fa13762e67fce2688da6706fc78
DIST tornado-4.4.2.tar.gz 460193 SHA256 2898f992f898cd41eeb8d53b6df75495f2f423b6672890aadaf196ea1448edcc SHA512 f330bc62433576708e3c566577cede07c54c19996f374df82d5abc19a669ade549e7b6c27dcae3d421921fec506fae39473443cdb04692553c5ea2f8ec11a327 WHIRLPOOL df04a35ed30f9bbaff87be06c96de7a9038e1535b21d40906eb92a5beeaaf6ac4ea1b14b4f16df1527b9a07d41a5ee4c04ec141a068e3acfb4b6717019ff5fdd
diff --git a/www-servers/tornado/files/drop-intersphinx.patch b/www-servers/tornado/files/drop-intersphinx.patch
deleted file mode 100644
index 7502dc53b820..000000000000
--- a/www-servers/tornado/files/drop-intersphinx.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff --git a/docs/Makefile b/docs/Makefile
-index 7001b80..ab2ffdd 100644
---- a/docs/Makefile
-+++ b/docs/Makefile
-@@ -3,7 +3,7 @@ all: sphinx
-
- # No -W for doctests because that disallows tests with empty output.
- SPHINX_DOCTEST_OPTS=-n -d build/doctress .
--SPHINXOPTS=-n -W -d build/doctrees .
-+SPHINXOPTS=-n -d build/doctrees .
-
- .PHONY: sphinx
- sphinx:
-diff --git a/docs/conf.py b/docs/conf.py
-index 368e4e8..85a276d 100644
---- a/docs/conf.py
-+++ b/docs/conf.py
-@@ -16,7 +16,6 @@ extensions = [
- "sphinx.ext.coverage",
- "sphinx.ext.doctest",
- "sphinx.ext.extlinks",
-- "sphinx.ext.intersphinx",
- "sphinx.ext.viewcode",
- ]
-
-@@ -91,10 +90,6 @@ extlinks = {
- 'tornado-%s.tar.g' % version),
- }
-
--intersphinx_mapping = {
-- 'python': ('https://docs.python.org/3.4/', None),
-- }
--
- on_rtd = os.environ.get('READTHEDOCS', None) == 'True'
-
- # On RTD we can't import sphinx_rtd_theme, but it will be applied by
diff --git a/www-servers/tornado/files/tornado-4.2.1-py3.5-backport.patch b/www-servers/tornado/files/tornado-4.2.1-py3.5-backport.patch
deleted file mode 100644
index e649935d7048..000000000000
--- a/www-servers/tornado/files/tornado-4.2.1-py3.5-backport.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 2971e857104f8d02fa9107a0e13f50170eb4f30d Mon Sep 17 00:00:00 2001
-From: Ben Darnell <ben@bendarnell.com>
-Date: Sat, 6 Jun 2015 15:40:21 -0400
-Subject: [PATCH] Get the tests passing under Python 3.5b2
-
----
- tornado/test/web_test.py | 7 +++++--
- tornado/util.py | 10 ++++++++--
- 2 files changed, 13 insertions(+), 4 deletions(-)
-
-diff --git a/tornado/test/web_test.py b/tornado/test/web_test.py
-index 96edd6c..a93369c 100644
---- a/tornado/test/web_test.py
-+++ b/tornado/test/web_test.py
-@@ -1538,8 +1538,11 @@ def get(self):
- def test_clear_all_cookies(self):
- response = self.fetch('/', headers={'Cookie': 'foo=bar; baz=xyzzy'})
- set_cookies = sorted(response.headers.get_list('Set-Cookie'))
-- self.assertTrue(set_cookies[0].startswith('baz=;'))
-- self.assertTrue(set_cookies[1].startswith('foo=;'))
-+ # Python 3.5 sends 'baz="";'; older versions use 'baz=;'
-+ self.assertTrue(set_cookies[0].startswith('baz=;') or
-+ set_cookies[0].startswith('baz="";'))
-+ self.assertTrue(set_cookies[1].startswith('foo=;') or
-+ set_cookies[1].startswith('foo="";'))
-
-
- class PermissionError(Exception):
-diff --git a/tornado/util.py b/tornado/util.py
-index 606ced1..ea4da87 100644
---- a/tornado/util.py
-+++ b/tornado/util.py
-@@ -13,7 +13,6 @@
- from __future__ import absolute_import, division, print_function, with_statement
-
- import array
--import inspect
- import os
- import sys
- import zlib
-@@ -24,6 +23,13 @@
- except NameError:
- xrange = range # py3
-
-+# inspect.getargspec() raises DeprecationWarnings in Python 3.5.
-+# The two functions have compatible interfaces for the parts we need.
-+try:
-+ from inspect import getfullargspec as getargspec # py3
-+except ImportError:
-+ from inspect import getargspec # py2
-+
-
- class ObjectDict(dict):
- """Makes a dictionary behave like an object, with attribute-style access.
-@@ -284,7 +290,7 @@ class ArgReplacer(object):
- def __init__(self, func, name):
- self.name = name
- try:
-- self.arg_pos = inspect.getargspec(func).args.index(self.name)
-+ self.arg_pos = getargspec(func).args.index(self.name)
- except ValueError:
- # Not a positional parameter
- self.arg_pos = None
diff --git a/www-servers/tornado/tornado-4.2.1.ebuild b/www-servers/tornado/tornado-4.2.1.ebuild
deleted file mode 100644
index d820fce8f6fd..000000000000
--- a/www-servers/tornado/tornado-4.2.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python web framework and asynchronous networking library"
-HOMEPAGE="http://www.tornadoweb.org/ https://pypi.python.org/pypi/tornado"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-CDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'virtual/python-asyncio[${PYTHON_USEDEP}]' 'python3*')
- $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' 'python2_7')
- $(python_gen_cond_dep 'dev-python/twisted-names[${PYTHON_USEDEP}]' 'python2_7')
- $(python_gen_cond_dep 'dev-python/twisted-web[${PYTHON_USEDEP}]' 'python2_7')
- virtual/python-backports_abc[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]
- virtual/python-singledispatch[${PYTHON_USEDEP}]
-"
-# dev-python/twisted-* only supports python2_7 currently
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? (
- ${CDEPEND}
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
- )
-"
-RDEPEND="${CDEPEND}"
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/drop-intersphinx.patch
- "${FILESDIR}"/${P}-py3.5-backport.patch
- )
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs sphinx
-}
-
-python_test() {
- "${PYTHON}" -m tornado.test.runtests || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- use examples && local EXAMPLES=( demos/. )
-
- distutils-r1_python_install_all
-}
diff --git a/www-servers/tornado/tornado-4.3.ebuild b/www-servers/tornado/tornado-4.3.ebuild
deleted file mode 100644
index 98dcd7392130..000000000000
--- a/www-servers/tornado/tornado-4.3.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python web framework and asynchronous networking library"
-HOMEPAGE="http://www.tornadoweb.org/ https://pypi.python.org/pypi/tornado"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-CDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'virtual/python-asyncio[${PYTHON_USEDEP}]' 'python3*')
- $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' 'python2_7')
- $(python_gen_cond_dep 'dev-python/twisted-names[${PYTHON_USEDEP}]' 'python2_7')
- $(python_gen_cond_dep 'dev-python/twisted-web[${PYTHON_USEDEP}]' 'python2_7')
- virtual/python-backports_abc[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]
- virtual/python-singledispatch[${PYTHON_USEDEP}]
-"
-# dev-python/twisted-* only supports python2_7 currently
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? (
- ${CDEPEND}
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
- )
-"
-RDEPEND="${CDEPEND}"
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/drop-intersphinx.patch
- )
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs sphinx
-}
-
-python_test() {
- "${PYTHON}" -m tornado.test.runtests || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- use examples && local EXAMPLES=( demos/. )
-
- distutils-r1_python_install_all
-}