summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/radeontop/radeontop-0.8.ebuild')
-rw-r--r--x11-apps/radeontop/radeontop-0.8.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-apps/radeontop/radeontop-0.8.ebuild b/x11-apps/radeontop/radeontop-0.8.ebuild
new file mode 100644
index 000000000000..fc899a072713
--- /dev/null
+++ b/x11-apps/radeontop/radeontop-0.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to view Radeon GPU utilization"
+HOMEPAGE="https://github.com/clbr/radeontop"
+LICENSE="GPL-3"
+SRC_URI="https://github.com/clbr/radeontop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ sys-libs/ncurses
+ x11-libs/libpciaccess
+ x11-libs/libdrm
+ nls? ( sys-libs/ncurses[unicode] virtual/libintl )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ epatch_user
+
+cat > include/version.h << EOF || die
+#ifndef VER_H
+#define VER_H
+
+#define VERSION "${PV}"
+
+#endif
+EOF
+ >getver.sh || die
+ touch .git || die
+}
+
+src_configure() {
+ tc-export CC
+ export nls=$(usex nls 1 0)
+ # Do not add -g or -s to CFLAGS
+ export plain=1
+}