summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/whyteboard/whyteboard-0.41.1-r1.ebuild')
-rw-r--r--x11-apps/whyteboard/whyteboard-0.41.1-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-apps/whyteboard/whyteboard-0.41.1-r1.ebuild b/x11-apps/whyteboard/whyteboard-0.41.1-r1.ebuild
new file mode 100644
index 000000000000..9d13028f704d
--- /dev/null
+++ b/x11-apps/whyteboard/whyteboard-0.41.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1 multilib
+
+DESCRIPTION="A simple image, PDF and postscript file annotator"
+HOMEPAGE="http://whyteboard.org/"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.gz
+ https://dev.gentoo.org/~lxnay/${PN}/${PN}.png"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/wxpython:*[${PYTHON_MULTI_USEDEP}]
+ ')
+ media-gfx/imagemagick"
+
+src_install() {
+ doicon "${DISTDIR}"/${PN}.png
+ domenu "${FILESDIR}"/${PN}.desktop
+
+ dodoc CHANGELOG.txt DEVELOPING.txt README.txt TODO.txt
+
+ python_domodule images locale ${PN} ${PN}-help ${PN}.py
+
+ cat >> "${T}/${PN}" <<- EOF
+ #!/bin/sh
+ exec ${PYTHON} -O "$(python_get_sitedir)/${PN}/${PN}.py"
+ EOF
+ dobin "${T}/${PN}"
+
+ python_optimize
+}
+
+pkg_preinst() {
+ echo
+ elog "This application is very experimental and some features"
+ elog "are not yet implemented, however you can live with it"
+ echo
+}