summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.0.0.ebuild')
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.0.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.0.0.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.0.0.ebuild
new file mode 100644
index 000000000000..90a061997083
--- /dev/null
+++ b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-18.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+XORG_DRI="always"
+inherit xorg-2
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
+
+RDEPEND=">=x11-libs/libdrm-2.4.78[video_cards_amdgpu]
+ x11-base/xorg-server[glamor(-)]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS="--enable-glamor"
+ xorg-2_src_configure
+}