summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-ati/Manifest1
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-18.0.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-ati/Manifest b/x11-drivers/xf86-video-ati/Manifest
index 56539cf8e096..b2f727ddc511 100644
--- a/x11-drivers/xf86-video-ati/Manifest
+++ b/x11-drivers/xf86-video-ati/Manifest
@@ -1,2 +1,3 @@
+DIST xf86-video-ati-18.0.0.tar.bz2 880807 BLAKE2B fba7ac98ab9e1c103c507ff2e52d10c82d975df1e7d8f19b67e4e631cbc1126f2a51a01068860b612210aa6d187c27ae5eceea616a33330f177d040bf1c063c5 SHA512 a9a634091f208099885039d42433cee061e03968417c0d535691833abcc9162d8d0a46f99bac902f0885beb14dcc9a011d104b535ffe492562fd5bb740ad4721
DIST xf86-video-ati-7.10.0.tar.bz2 876442 BLAKE2B f1c36e215d10c655dc6cf6059a273241e8b33f53df06c66c13dbef436c2b4f967f5c6c60858a484bbffe05bc6fffd9b8c20733ba9928051d6b0f28fe02fcdf1b SHA512 1f2f4af1d299af62644693e6fbc47a5078c9bc5e7887a1ac217121ef2fd29d8c9f50a8d9be9ddb0887d0b49141bb33484f82c1313a472ad6867266b53b4a11ad
DIST xf86-video-ati-7.9.0.tar.bz2 848502 BLAKE2B 0572ef3cba7a3704470b4611f755a29a2551acc6fa544fb03f37a88628d5dfecba8342c8558b8355f245f2582eb46d17fb92b8713378161da3d103215e66d883 SHA512 125e035da6581520d677c56474653ed75aa6d168bf5450cc973248416b5ada3114ea14d0615b44c58029bb1702609453ab532a506273df2a5dd99dd2af4a9d43
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-18.0.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-18.0.0.ebuild
new file mode 100644
index 000000000000..3bb9e4ef6269
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-18.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_DRI=always
+inherit linux-info xorg-2
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="ATI video driver"
+HOMEPAGE="https://www.x.org/wiki/ati/"
+
+IUSE="+glamor udev"
+
+RDEPEND=">=x11-libs/libdrm-2.4.78[video_cards_radeon]
+ >=x11-libs/libpciaccess-0.8.0
+ glamor? ( x11-base/xorg-server[glamor] )
+ udev? ( virtual/udev )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ if kernel_is -ge 3 9; then
+ CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
+ else
+ CONFIG_CHECK="~DRM_RADEON_KMS ~!FB_RADEON"
+ fi
+ fi
+ check_extra_config
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable glamor)
+ $(use_enable udev)
+ )
+ xorg-2_src_configure
+}