summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libview')
-rw-r--r--x11-libs/libview/Manifest1
-rw-r--r--x11-libs/libview/files/libview-0.5.6-pcfix.patch17
-rw-r--r--x11-libs/libview/libview-0.6.6-r2.ebuild38
-rw-r--r--x11-libs/libview/metadata.xml10
4 files changed, 66 insertions, 0 deletions
diff --git a/x11-libs/libview/Manifest b/x11-libs/libview/Manifest
new file mode 100644
index 000000000000..4daf52084aa7
--- /dev/null
+++ b/x11-libs/libview/Manifest
@@ -0,0 +1 @@
+DIST libview-0.6.6.tar.bz2 304958 SHA256 2b991bf150c5488b43f807e89bdbd64b2eb3bd433abbdfb68c3eec52cbaa59ab SHA512 28f710130c70b45f7a4601ff65aee5092641d53ba74d2c44a4e33e2c9d2bcae82abd86e8458fa64ae8cf7c04c6dd1dc7e6af8084201398e373b7cd146ea6c880 WHIRLPOOL 158b421da29a98989e48413906e0b178f89ba015eb23f69d65586a04f819271fb89d5b1e8cc80371dcada033b5f2acba2b982a09972e61bc0279127ed699eb48
diff --git a/x11-libs/libview/files/libview-0.5.6-pcfix.patch b/x11-libs/libview/files/libview-0.5.6-pcfix.patch
new file mode 100644
index 000000000000..8df5d414da94
--- /dev/null
+++ b/x11-libs/libview/files/libview-0.5.6-pcfix.patch
@@ -0,0 +1,17 @@
+--- libview.pc.in
++++ libview.pc.in
+@@ -1,9 +1,11 @@
+-prefix=${prefix}
++prefix=@prefix@
++exec_prefix=${prefix}
+ libdir=${exec_prefix}/lib
+ includedir=${prefix}/include
+
+ Name: libview
+ Description: VMware's Incredibly Exciting Widgets for GTK+
+ Version: @VERSION@
+-Libs: -L${libdir} -lview @PACKAGE_LIBS@
+-Cflags: -I${includedir} @PACKAGE_CFLAGS@
++Libs: -L${libdir} -lview
++Libs.private: @VIEW_LIBS@
++Cflags: -I${includedir} @VIEW_CFLAGS@
diff --git a/x11-libs/libview/libview-0.6.6-r2.ebuild b/x11-libs/libview/libview-0.6.6-r2.ebuild
new file mode 100644
index 000000000000..5ae6e983563f
--- /dev/null
+++ b/x11-libs/libview/libview-0.6.6-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="VMware's Incredibly Exciting Widgets"
+HOMEPAGE="http://view.sourceforge.net"
+SRC_URI="mirror://sourceforge/view/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.4.0:2
+ dev-cpp/gtkmm:2.4
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix the pkgconfig file
+ epatch "${FILESDIR}"/${PN}-0.5.6-pcfix.patch
+ eautoreconf -i
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-deprecated \
+ $(use_enable static-libs static)
+}
diff --git a/x11-libs/libview/metadata.xml b/x11-libs/libview/metadata.xml
new file mode 100644
index 000000000000..d34f18b75014
--- /dev/null
+++ b/x11-libs/libview/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vmware</herd>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">view</remote-id>
+ </upstream>
+</pkgmetadata>