summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/bbacpi/bbacpi-0.1.5-r4.ebuild')
-rw-r--r--x11-misc/bbacpi/bbacpi-0.1.5-r4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/bbacpi/bbacpi-0.1.5-r4.ebuild b/x11-misc/bbacpi/bbacpi-0.1.5-r4.ebuild
new file mode 100644
index 000000000000..af95439a9bd0
--- /dev/null
+++ b/x11-misc/bbacpi/bbacpi-0.1.5-r4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="ACPI monitor for X11"
+HOMEPAGE="https://bbacpi.sourceforge.net"
+SRC_URI="https://downloads.sourceforge.net/bbacpi/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+
+DEPEND="
+ media-libs/imlib
+ sys-power/acpi
+ sys-power/acpid
+ x11-libs/libX11
+ x11-misc/xdialog"
+RDEPEND="
+ ${DEPEND}
+ media-fonts/font-adobe-100dpi"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-noextraquals.diff
+ "${FILESDIR}"/${P}-overflows.diff
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc data/README.bbacpi
+
+ rm "${ED}"/usr/share/bbtools/README.bbacpi || die
+}