summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/bbppp/bbppp-0.2.5-r1.ebuild')
-rw-r--r--x11-misc/bbppp/bbppp-0.2.5-r1.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/x11-misc/bbppp/bbppp-0.2.5-r1.ebuild b/x11-misc/bbppp/bbppp-0.2.5-r1.ebuild
index a8e1a0cdbba4..c0c325534a94 100644
--- a/x11-misc/bbppp/bbppp-0.2.5-r1.ebuild
+++ b/x11-misc/bbppp/bbppp-0.2.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,14 +7,16 @@ inherit autotools
DESCRIPTION="blackbox ppp frontend/monitor"
HOMEPAGE="https://sourceforge.net/projects/bbtools/"
-SRC_URI="mirror://sourceforge/bbtools/${PN}/${P}/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/bbtools/${PN}/${P}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-DEPEND="x11-libs/libX11"
-RDEPEND="${DEPEND}
+COMMON_DEPEND="x11-libs/libX11"
+DEPEND="${COMMON_DEPEND}
+ elibc_musl? ( net-libs/ppp-defs )"
+RDEPEND="${COMMON_DEPEND}
media-fonts/font-adobe-100dpi"
PATCHES=(
@@ -26,6 +28,9 @@ PATCHES=(
src_prepare() {
default
mv configure.{in,ac} || die
+ sed -i \
+ -e 's|register ||' \
+ Image.cc LinkedList.cc || die
eautoreconf
}