summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/bbrun/bbrun-1.6-r1.ebuild')
-rw-r--r--x11-misc/bbrun/bbrun-1.6-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/x11-misc/bbrun/bbrun-1.6-r1.ebuild b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
index 0ae88b552435..a6a1b752e378 100644
--- a/x11-misc/bbrun/bbrun-1.6-r1.ebuild
+++ b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,7 +29,14 @@ PATCHES=(
"${FILESDIR}"/${P}-gcc-10.patch
)
+src_prepare() {
+ default
+ sed -i -e "/LIBDIR =/s:lib:$(get_libdir):" bbrun/Makefile || die
+}
+
src_compile() {
+ tc-export PKG_CONFIG
+
emake -C ${PN} CC="$(tc-getCC)"
}