summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/bumblebee')
-rw-r--r--x11-misc/bumblebee/Manifest1
-rw-r--r--x11-misc/bumblebee/bumblebee-3.2.1.ebuild73
-rw-r--r--x11-misc/bumblebee/files/bumblebee.confd3
-rw-r--r--x11-misc/bumblebee/files/bumblebee.envd3
-rw-r--r--x11-misc/bumblebee/files/bumblebee.initd23
-rw-r--r--x11-misc/bumblebee/metadata.xml26
6 files changed, 129 insertions, 0 deletions
diff --git a/x11-misc/bumblebee/Manifest b/x11-misc/bumblebee/Manifest
new file mode 100644
index 000000000000..eefc4b2817f5
--- /dev/null
+++ b/x11-misc/bumblebee/Manifest
@@ -0,0 +1 @@
+DIST bumblebee-3.2.1.tar.gz 143110 SHA256 1018703b07e2f607a4641249d69478ce076ae5a1e9dd6cff5694d394fa7ee30e SHA512 6f016f75d199577215ff00c059e196829e9d3efeb0fb6eebe6c3fad6176e330332e1ef25875a22ac9892895683d95899ea44f1ec1f85d31300ad83cb1fe0310a WHIRLPOOL 0d59b205f3c57afbf3fa6c8a55964afed8684e57db045e4c333c8e94f0b5d91637963a0b9f386eb6fe655716b8854e82ae5724dacdc76a34de6eb1f99ffc4908
diff --git a/x11-misc/bumblebee/bumblebee-3.2.1.ebuild b/x11-misc/bumblebee/bumblebee-3.2.1.ebuild
new file mode 100644
index 000000000000..60d7b3413d42
--- /dev/null
+++ b/x11-misc/bumblebee/bumblebee-3.2.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib readme.gentoo systemd user
+
+DESCRIPTION="Service providing elegant and stable means of managing Optimus graphics chipsets"
+HOMEPAGE="http://bumblebee-project.org https://github.com/Bumblebee-Project/Bumblebee"
+SRC_URI="http://bumblebee-project.org/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="amd64 x86"
+
+IUSE="+bbswitch video_cards_nouveau video_cards_nvidia"
+
+RDEPEND="
+ dev-libs/libbsd
+ virtual/opengl
+ x11-base/xorg-drivers[video_cards_nvidia?,video_cards_nouveau?]
+ x11-misc/virtualgl:=
+ bbswitch? ( sys-power/bbswitch )
+"
+DEPEND="${RDEPEND}
+ dev-libs/glib:2
+ sys-apps/help2man
+ virtual/pkgconfig
+ x11-libs/libX11
+"
+
+REQUIRED_USE="|| ( video_cards_nouveau video_cards_nvidia )"
+
+src_configure() {
+ DOC_CONTENTS="In order to use Bumblebee, add your user to 'bumblebee' group.
+ You may need to setup your /etc/bumblebee/bumblebee.conf"
+
+ if use video_cards_nvidia ; then
+ # Get paths to GL libs for all ABIs
+ local nvlib=""
+ for i in $(get_all_libdirs) ; do
+ nvlib="${nvlib}:/usr/${i}/opengl/nvidia/lib"
+ done
+
+ local nvpref="/usr/$(get_libdir)/opengl/nvidia"
+ local xorgpref="/usr/$(get_libdir)/xorg/modules"
+ ECONF_PARAMS="CONF_DRIVER=nvidia CONF_DRIVER_MODULE_NVIDIA=nvidia \
+ CONF_LDPATH_NVIDIA=${nvlib#:} \
+ CONF_MODPATH_NVIDIA=${nvpref}/lib,${nvpref}/extensions,${xorgpref}/drivers,${xorgpref}"
+ fi
+
+ econf \
+ --docdir=/usr/share/doc/"${PF}" \
+ ${ECONF_PARAMS}
+}
+
+src_install() {
+ newconfd "${FILESDIR}"/bumblebee.confd bumblebee
+ newinitd "${FILESDIR}"/bumblebee.initd bumblebee
+ newenvd "${FILESDIR}"/bumblebee.envd 99bumblebee
+ systemd_dounit scripts/systemd/bumblebeed.service
+
+ readme.gentoo_create_doc
+
+ default
+}
+
+pkg_preinst() {
+ use video_cards_nvidia || rm "${ED}"/etc/bumblebee/xorg.conf.nvidia
+ use video_cards_nouveau || rm "${ED}"/etc/bumblebee/xorg.conf.nouveau
+
+ enewgroup bumblebee
+}
diff --git a/x11-misc/bumblebee/files/bumblebee.confd b/x11-misc/bumblebee/files/bumblebee.confd
new file mode 100644
index 000000000000..1c70206da6bf
--- /dev/null
+++ b/x11-misc/bumblebee/files/bumblebee.confd
@@ -0,0 +1,3 @@
+# /etc/conf.d/bumblebee
+
+BUMBLEBEE_EXTRA_OPTS="--use-syslog" \ No newline at end of file
diff --git a/x11-misc/bumblebee/files/bumblebee.envd b/x11-misc/bumblebee/files/bumblebee.envd
new file mode 100644
index 000000000000..e19cc56a1303
--- /dev/null
+++ b/x11-misc/bumblebee/files/bumblebee.envd
@@ -0,0 +1,3 @@
+# Comment this out if you are using VirtualGL also for other purposes and this
+# slows down things for you.
+VGL_READBACK="pbo"
diff --git a/x11-misc/bumblebee/files/bumblebee.initd b/x11-misc/bumblebee/files/bumblebee.initd
new file mode 100644
index 000000000000..fb618305cb32
--- /dev/null
+++ b/x11-misc/bumblebee/files/bumblebee.initd
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need xdm vgl
+}
+
+PIDFILE="${PIDFILE:-/var/run/bumblebee.pid}"
+
+start() {
+ ebegin "Starting BumbleBee Daemon"
+ start-stop-daemon -S -p "${PIDFILE}" -x /usr/sbin/bumblebeed -- -D ${BUMBLEBEE_EXTRA_OPTS} --pidfile "${PIDFILE}"
+ eend $?
+}
+
+stop() {
+
+ ebegin "Stopping BumbleBee Daemon"
+ start-stop-daemon -K -p "${PIDFILE}" -R SIGTERM/10
+ eend $?
+}
diff --git a/x11-misc/bumblebee/metadata.xml b/x11-misc/bumblebee/metadata.xml
new file mode 100644
index 000000000000..15a5547eef62
--- /dev/null
+++ b/x11-misc/bumblebee/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+ </maintainer>
+ <maintainer>
+ <email>rei4dan@gmail.com</email>
+ <name>My Th</name>
+ </maintainer>
+ <longdescription>
+ A rewrite of the original Bumblebee service, providing an elegant and stable
+ means of managing Optimus hybrid graphics chipsets. A primary goal of this
+ project is to not only enable use of the discrete GPU for rendering, but
+ also to enable smart power management of the dGPU when it's not in use.
+</longdescription>
+ <use>
+ <flag name="bbswitch">Add dependency on <pkg>sys-kernel/bbswitch</pkg> for
+ PM feature</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">Bumblebee-Project/Bumblebee</remote-id>
+ </upstream>
+</pkgmetadata>