summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/cairo-clock/cairo-clock-0.3.4-r1.ebuild')
-rw-r--r--x11-misc/cairo-clock/cairo-clock-0.3.4-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/cairo-clock/cairo-clock-0.3.4-r1.ebuild b/x11-misc/cairo-clock/cairo-clock-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..beeae3cafbb2
--- /dev/null
+++ b/x11-misc/cairo-clock/cairo-clock-0.3.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="An analog clock displaying the system-time"
+HOMEPAGE="https://launchpad.net/cairo-clock"
+SRC_URI="http://macslow.thepimp.net/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=gnome-base/libglade-2.6
+ >=gnome-base/librsvg-2.14
+ >=x11-libs/cairo-1.2
+ >=x11-libs/gtk+-2.10:2
+ >=x11-libs/pango-1.10"
+DEPEND="${DEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-desktop.patch
+ "${FILESDIR}"/${P}-linker.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}