summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/evolvotron')
-rw-r--r--x11-misc/evolvotron/evolvotron-0.6.3-r1.ebuild51
-rw-r--r--x11-misc/evolvotron/files/evolvotron-0.6.3-gcc6.patch15
2 files changed, 66 insertions, 0 deletions
diff --git a/x11-misc/evolvotron/evolvotron-0.6.3-r1.ebuild b/x11-misc/evolvotron/evolvotron-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..6d52be1f0b27
--- /dev/null
+++ b/x11-misc/evolvotron/evolvotron-0.6.3-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit qmake-utils
+
+DESCRIPTION="Generative art image evolver"
+HOMEPAGE="https://sourceforge.net/projects/evolvotron/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=( "${FILESDIR}"/${P}-gcc6.patch )
+
+DOCS=( BUGS NEWS README TODO USAGE )
+HTML_DOCS=( evolvotron.html )
+
+src_configure() {
+ eqmake4 main.pro
+}
+
+src_compile() {
+ local etsubdir
+ for etsubdir in \
+ libfunction libevolvotron evolvotron evolvotron_render evolvotron_mutate
+ do
+ emake sub-${etsubdir}
+ done
+}
+
+src_install() {
+ local bin
+ for bin in ${PN}{,_mutate,_render}; do
+ dobin ${bin}/${bin}
+ done
+ doman man/man1/*
+ einstalldocs
+}
diff --git a/x11-misc/evolvotron/files/evolvotron-0.6.3-gcc6.patch b/x11-misc/evolvotron/files/evolvotron-0.6.3-gcc6.patch
new file mode 100644
index 000000000000..709d61b29a6a
--- /dev/null
+++ b/x11-misc/evolvotron/files/evolvotron-0.6.3-gcc6.patch
@@ -0,0 +1,15 @@
+Description: Fix compilation with GCC6 by making implict conversion to bool explicit
+Author: Axel Beckert <abe@debian.org>
+Bug-Debian: https://bugs.debian.org/811660
+
+--- a/libevolvotron/mutatable_image_computer.h
++++ b/libevolvotron/mutatable_image_computer.h
+@@ -193,7 +193,7 @@
+ //! Indicate whether computation us taking place (only intended for counting outstanding threads).
+ bool active() const
+ {
+- return _task;
++ return (bool)_task;
+ }
+ };
+