summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/gdevilspie')
-rw-r--r--x11-misc/gdevilspie/Manifest1
-rw-r--r--x11-misc/gdevilspie/files/gdevilspie-0.5-paths.patch84
-rw-r--r--x11-misc/gdevilspie/gdevilspie-0.5-r1.ebuild35
-rw-r--r--x11-misc/gdevilspie/metadata.xml8
4 files changed, 128 insertions, 0 deletions
diff --git a/x11-misc/gdevilspie/Manifest b/x11-misc/gdevilspie/Manifest
new file mode 100644
index 000000000000..c9b3dd935dee
--- /dev/null
+++ b/x11-misc/gdevilspie/Manifest
@@ -0,0 +1 @@
+DIST gdevilspie-0.5.tar.bz2 29028 SHA256 e03ab813e56b6dc6d868db7c318d280c9864cfa6e8a4ca84a5bb5d05542f55ff SHA512 0426b58c37b3078185abf8f3100f1da982b58e789c68b8f2f1b4e6e6f4befbaf12782b9790be5a1e90ee432a46cc1a91a69997c54796c756276e59533dccb388 WHIRLPOOL 43c7220c44ef005289bb3f9eaada51eb6bac42dba00920e4d55c029262289ee43b6d8c498c8daa48bffb0194c93d852bc471d98e09a808799b58f59e12636454
diff --git a/x11-misc/gdevilspie/files/gdevilspie-0.5-paths.patch b/x11-misc/gdevilspie/files/gdevilspie-0.5-paths.patch
new file mode 100644
index 000000000000..771501b0045e
--- /dev/null
+++ b/x11-misc/gdevilspie/files/gdevilspie-0.5-paths.patch
@@ -0,0 +1,84 @@
+--- /home/usuario/Escritorio/gdevilspie 2015-04-26 03:30:16.760326671 -0300
++++ /usr/lib/python-exec/python2.7/gdevilspie 2015-04-26 03:32:11.247227671 -0300
+@@ -48,6 +48,10 @@
+ DISABLE_XDG=""
+ try:
+ import xdg.DesktopEntry
++ if xdg.DesktopEntry.__dict__.has_key('xdg_config_home') == True:
++ xdg_config_home = xdg.DesktopEntry.xdg_config_home
++ else:
++ xdg_config_home = os.path.join(os.environ["HOME"], "config")
+ except:
+ error = gtk.MessageDialog(None, 0, gtk.MESSAGE_ERROR, gtk.BUTTONS_CLOSE, "Make sure that Python-xdg is correctly installed if you need autostart handling.")
+ response = error.run()
+@@ -300,22 +304,32 @@
+ return strous
+
+ # Glade file used in all classes
+-if os.path.isfile(os.path.dirname(sys.argv[0])+'/gdevilspie.glade'):
+- gladefile = os.path.dirname(sys.argv[0])+'/gdevilspie.glade'
+-elif os.path.isfile(os.path.dirname(sys.argv[0]) + '/../share/gdevilspie/gdevilspie.glade'):
+- gladefile = os.path.dirname(sys.argv[0])+'/../share/gdevilspie/gdevilspie.glade'
+-else:
+- gtk.MessageDialog(None, 0, gtk.MESSAGE_ERROR, gtk.BUTTONS_CLOSE, "Glade file not found, exiting.").run()
+- quit()
++for syspath in os.environ["PATH"].split(":"):
++ if os.path.isfile(os.path.dirname(syspath) + '/../share/gdevilspie/gdevilspie.glade'):
++ gladefile = os.path.dirname(syspath)+'/../share/gdevilspie/gdevilspie.glade'
++ break
++if "gladefile" not in globals():
++ if os.path.isfile(os.path.dirname(sys.argv[0])+'/gdevilspie.glade'):
++ gladefile = os.path.dirname(sys.argv[0])+'/gdevilspie.glade'
++ elif os.path.isfile(os.path.dirname(sys.argv[0]) + '/../share/gdevilspie/gdevilspie.glade'):
++ gladefile = os.path.dirname(sys.argv[0])+'/../share/gdevilspie/gdevilspie.glade'
++ else:
++ gtk.MessageDialog(None, 0, gtk.MESSAGE_ERROR, gtk.BUTTONS_CLOSE, "Glade file not found, exiting.").run()
++ quit()
+
+
+ # icon used
+-if os.path.isfile(os.path.dirname(sys.argv[0])+'/gdevilspie.png'):
+- gdevilspie_icon = os.path.dirname(sys.argv[0])+'/gdevilspie.png'
+-elif os.path.isfile(os.path.dirname(sys.argv[0]) + '/../share/gdevilspie/gdevilspie.png'):
+- gdevilspie_icon = os.path.dirname(sys.argv[0])+'/../share/gdevilspie/gdevilspie.png'
+-else:
+- gtk.MessageDialog(None, 0, gtk.MESSAGE_ERROR, gtk.BUTTONS_CLOSE, "Icon file not found.").run()
++for syspath in os.environ["PATH"].split(":"):
++ if os.path.isfile(os.path.dirname(syspath) + '/../share/gdevilspie/gdevilspie.png'):
++ gdevilspie_icon = os.path.dirname(syspath)+'/../share/gdevilspie/gdevilspie.png'
++ break
++if "gdevilspie_icon" not in globals():
++ if os.path.isfile(os.path.dirname(sys.argv[0])+'/gdevilspie.png'):
++ gdevilspie_icon = os.path.dirname(sys.argv[0])+'/gdevilspie.png'
++ elif os.path.isfile(os.path.dirname(sys.argv[0]) + '/../share/gdevilspie/gdevilspie.png'):
++ gdevilspie_icon = os.path.dirname(sys.argv[0])+'/../share/gdevilspie/gdevilspie.png'
++ else:
++ gtk.MessageDialog(None, 0, gtk.MESSAGE_ERROR, gtk.BUTTONS_CLOSE, "Icon file not found.").run()
+
+ # Directory where we store .ds files
+ dir = os.path.expanduser("~/.devilspie")
+@@ -542,12 +556,12 @@
+ if ( DISABLE_XDG == "True" ):
+ self.DaemonAutostart.set_sensitive(False)
+ else:
+- if (os.path.exists(xdg.DesktopEntry.xdg_config_home + "/autostart/devilspie.desktop")):
+- df = xdg.DesktopEntry.DesktopEntry(xdg.DesktopEntry.xdg_config_home + "/autostart/devilspie.desktop")
++ if (os.path.exists(xdg_config_home + "/autostart/devilspie.desktop")):
++ df = xdg.DesktopEntry.DesktopEntry(xdg_config_home + "/autostart/devilspie.desktop")
+ if (df.get('X-GNOME-Autostart-enabled') == 'true'):
+ self.DaemonAutostart.set_active(True)
+ else:
+- df = xdg.DesktopEntry.DesktopEntry(xdg.DesktopEntry.xdg_config_home + "/autostart/devilspie.desktop")
++ df = xdg.DesktopEntry.DesktopEntry(xdg_config_home + "/autostart/devilspie.desktop")
+ df.set('Name','Devilspie')
+ df.set('Exec','devilspie')
+ df.set('X-GNOME-Autostart-enabled','false')
+@@ -555,7 +569,7 @@
+
+
+ def on_DaemonAutostart_toggled(self,widget):
+- df = xdg.DesktopEntry.DesktopEntry(xdg.DesktopEntry.xdg_config_home + "/autostart/devilspie.desktop")
++ df = xdg.DesktopEntry.DesktopEntry(xdg_config_home + "/autostart/devilspie.desktop")
+ if (widget.get_active()):
+ df.set('X-GNOME-Autostart-enabled','true')
+ df.write()
diff --git a/x11-misc/gdevilspie/gdevilspie-0.5-r1.ebuild b/x11-misc/gdevilspie/gdevilspie-0.5-r1.ebuild
new file mode 100644
index 000000000000..f1dfa9fb2255
--- /dev/null
+++ b/x11-misc/gdevilspie/gdevilspie-0.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A user friendly interface to the devilspie window matching daemon, to create rules easily"
+HOMEPAGE="http://code.google.com/p/gdevilspie/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/libwnck-python[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ x11-misc/devilspie
+"
+
+PATCHES=(
+ # Fix paths for finding XDG and glade file, bug #539638
+ "${FILESDIR}/${P}-paths.patch"
+)
+
+src_prepare() {
+ sed -i -e "s:doc/gdevilspie:doc/${PF}:" setup.py || die
+ distutils-r1_src_prepare
+}
diff --git a/x11-misc/gdevilspie/metadata.xml b/x11-misc/gdevilspie/metadata.xml
new file mode 100644
index 000000000000..70778a76521f
--- /dev/null
+++ b/x11-misc/gdevilspie/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <upstream>
+ <remote-id type="google-code">gdevilspie</remote-id>
+ </upstream>
+</pkgmetadata>