summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/grabc/files/grabc-1.1-makefile.patch')
-rw-r--r--x11-misc/grabc/files/grabc-1.1-makefile.patch32
1 files changed, 15 insertions, 17 deletions
diff --git a/x11-misc/grabc/files/grabc-1.1-makefile.patch b/x11-misc/grabc/files/grabc-1.1-makefile.patch
index 4815ae5675c5..80961ab40a04 100644
--- a/x11-misc/grabc/files/grabc-1.1-makefile.patch
+++ b/x11-misc/grabc/files/grabc-1.1-makefile.patch
@@ -1,6 +1,6 @@
---- grabc1.1/Makefile.org 1997-03-17 06:51:39.000000000 +0100
-+++ grabc1.1/Makefile 2010-02-08 12:18:34.000000000 +0100
-@@ -2,17 +2,15 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,30 +2,16 @@
# Makefile automatically generated by genmake 1.0, Mar-16-97
# genmake 1.0 by ma_muquit@fccc.edu, RCS
##
@@ -8,30 +8,28 @@
DEFS=
PROGNAME= grabc
-LIBS= -L/usr/X11R6/lib -lX11
-+LIBS= $(shell pkg-config --libs x11)
++LDLIBS= $(shell $(PKG_CONFIG) --libs x11)
INCLUDES= -I.
-# replace -O with -g in order to debug
-+# replace -O2 -pipe -Wall -march=athlon-xp with -g in order to debug
- DEFINES= $(INCLUDES) $(DEFS) -D__USE_FIXED_PROTOTYPES__ -DSYS_UNIX=1
+-DEFINES= $(INCLUDES) $(DEFS) -D__USE_FIXED_PROTOTYPES__ -DSYS_UNIX=1
-CFLAGS= -O $(DEFINES)
-
- SRCS = grabc.c
-
-@@ -20,12 +18,12 @@
-
- .c.o:
- rm -f $@
+-
+-SRCS = grabc.c
+-
+-OBJS = grabc.o
+-
+-.c.o:
+- rm -f $@
- $(CC) $(CFLAGS) -c $*.c
-+ $(CC) $(CFLAGS) $(DEFINES) -c $*.c
++CPPFLAGS += $(INCLUDES) $(DEFS) -D__USE_FIXED_PROTOTYPES__ -DSYS_UNIX=1
all: $(PROGNAME)
- $(PROGNAME) : $(OBJS)
+-$(PROGNAME) : $(OBJS)
- $(CC) $(CFLAGS) -o $(PROGNAME) $(OBJS) $(LIBS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $(PROGNAME) $(OBJS) $(LIBS)
-
+-
clean:
rm -f $(OBJS) $(PROGNAME) core