summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/gromit/files')
-rw-r--r--x11-misc/gromit/files/gromit-20041213-build.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/x11-misc/gromit/files/gromit-20041213-build.patch b/x11-misc/gromit/files/gromit-20041213-build.patch
new file mode 100644
index 000000000000..f61a13bcccd6
--- /dev/null
+++ b/x11-misc/gromit/files/gromit-20041213-build.patch
@@ -0,0 +1,19 @@
+Respect CC, CFLAGS, & LDFLAGS.
+Drop DEPRECATED flags for bug #387833.
+Fix underlinking for bug #369453.
+--- a/Makefile
++++ b/Makefile
+@@ -1,10 +1,10 @@
+ all: gromit
+
+ proptest: proptest.c
+- gcc -o proptest proptest.c `gtk-config --libs --cflags`
++ $(CC) -o proptest proptest.c `gtk-config --libs --cflags`
+
+ propertywatch: propertywatch.c
+- gcc -o propertywatch propertywatch.c `gtk-config --libs --cflags`
++ $(CC) -o propertywatch propertywatch.c `gtk-config --libs --cflags`
+
+ gromit: gromit.c Makefile
+- gcc -DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -o gromit gromit.c -Wall `pkg-config --libs --cflags gtk+-2.0`
++ $(CC) -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -o gromit gromit.c -Wall $(CFLAGS) $(LDFLAGS) `pkg-config --libs --cflags gtk+-2.0` -lX11 -lm