summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/gtkdialog/gtkdialog-99999.ebuild')
-rw-r--r--x11-misc/gtkdialog/gtkdialog-99999.ebuild51
1 files changed, 23 insertions, 28 deletions
diff --git a/x11-misc/gtkdialog/gtkdialog-99999.ebuild b/x11-misc/gtkdialog/gtkdialog-99999.ebuild
index 131519d09a46..4e8729405cba 100644
--- a/x11-misc/gtkdialog/gtkdialog-99999.ebuild
+++ b/x11-misc/gtkdialog/gtkdialog-99999.ebuild
@@ -1,37 +1,41 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit autotools git-r3 xdg-utils
+EAPI=8
+
+inherit autotools xdg
+
+if [[ "${PV}" == "99999" ]]; then
+ EGIT_REPO_URI="https://github.com/oshazard/gtkdialog"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~jsmolic/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
DESCRIPTION="A small utility for fast and easy GUI building"
HOMEPAGE="https://github.com/oshazard/gtkdialog"
-EGIT_REPO_URI="https://github.com/oshazard/gtkdialog"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-IUSE="gtk2"
RDEPEND="
- gtk2? (
- x11-libs/gtk+:2
- x11-libs/vte:0=
- )
- !gtk2? (
- x11-libs/gtk+:3
- x11-libs/vte:2.91=
- )
+ dev-libs/glib
+ x11-libs/gtk+:3
+ x11-libs/vte:2.91=
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
sys-apps/texinfo
- sys-devel/flex
+ app-alternatives/lex
virtual/pkgconfig
- virtual/yacc
+ app-alternatives/yacc
"
+
PATCHES=(
"${FILESDIR}"/${PN}-0.8.3-fno-common.patch
+ "${FILESDIR}"/${PN}-0.8.3-do_variables_count_widgets.patch
+ "${FILESDIR}"/${PN}-0.8.3-fix-build-for-clang16.patch
)
src_prepare() {
@@ -40,8 +44,7 @@ src_prepare() {
}
src_configure() {
- econf \
- $(usex gtk2 --disable-gtk3 --enable-gtk3)
+ econf --enable-gtk3
}
src_compile() {
@@ -54,11 +57,3 @@ src_install() {
emake DESTDIR="${D}" UPDATE_ICON_CACHE=true install
einstalldocs
}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}