summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/i3lock/i3lock-2.10-r1.ebuild')
-rw-r--r--x11-misc/i3lock/i3lock-2.10-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/i3lock/i3lock-2.10-r1.ebuild b/x11-misc/i3lock/i3lock-2.10-r1.ebuild
new file mode 100644
index 000000000000..7d7b4a6ef2dc
--- /dev/null
+++ b/x11-misc/i3lock/i3lock-2.10-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="https://i3wm.org/i3lock/"
+SRC_URI="https://i3wm.org/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE=""
+
+RDEPEND="
+ >=x11-libs/libxkbcommon-0.5.0[X]
+ dev-libs/libev
+ sys-libs/pam
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+DOCS=( CHANGELOG README.md )
+
+src_prepare() {
+ default
+
+ sed -i -e 's:login:system-auth:' ${PN}.pam || die
+
+ tc-export CC
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}