summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/mygestures/mygestures-2.0-r1.ebuild')
-rw-r--r--x11-misc/mygestures/mygestures-2.0-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/mygestures/mygestures-2.0-r1.ebuild b/x11-misc/mygestures/mygestures-2.0-r1.ebuild
new file mode 100644
index 000000000000..2a4e45a2e732
--- /dev/null
+++ b/x11-misc/mygestures/mygestures-2.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Mouse gestures for X"
+HOMEPAGE="https://github.com/deters/mygestures/"
+SRC_URI="
+ https://github.com/deters/mygestures/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libxml2
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-gcc14.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ dobin src/mygestures #814482
+
+ dodoc README.md
+
+ insinto /etc
+ doins mygestures.xml
+}