summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/notify-osd')
-rw-r--r--x11-misc/notify-osd/files/notify-osd-0.9.34-fix-integer-conversion.patch24
-rw-r--r--x11-misc/notify-osd/metadata.xml2
-rw-r--r--x11-misc/notify-osd/notify-osd-0.9.34-r2.ebuild (renamed from x11-misc/notify-osd/notify-osd-0.9.34-r1.ebuild)32
3 files changed, 41 insertions, 17 deletions
diff --git a/x11-misc/notify-osd/files/notify-osd-0.9.34-fix-integer-conversion.patch b/x11-misc/notify-osd/files/notify-osd-0.9.34-fix-integer-conversion.patch
new file mode 100644
index 000000000000..3dffeebf497b
--- /dev/null
+++ b/x11-misc/notify-osd/files/notify-osd-0.9.34-fix-integer-conversion.patch
@@ -0,0 +1,24 @@
+Clang16 will not allow implicit pointer to integer
+conversions by default. (-Werror=int-conversion by default)
+This patch fixes the pointer to integer conversion.
+
+Bug: https://bugs.gentoo.org/879035
+Patch is upstreamed here: https://answers.launchpad.net/notify-osd/+question/704024
+
+Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
+--- a/src/bubble-window.c
++++ b/src/bubble-window.c
+@@ -78,8 +78,8 @@ bubble_window_get_accessible (GtkWidget *widget)
+ {
+ AtkObjectFactory *factory = NULL;
+ AtkRegistry *registry = NULL;
+- GType derived_type = NULL;
+- GType derived_atk_type = NULL;
++ GType derived_type = 0;
++ GType derived_atk_type = 0;
+
+ /*
+ * Figure out whether accessibility is enabled by looking at the
+--
+2.38.1
+
diff --git a/x11-misc/notify-osd/metadata.xml b/x11-misc/notify-osd/metadata.xml
index 64dfa5cdb7f0..f3f2db90e3ea 100644
--- a/x11-misc/notify-osd/metadata.xml
+++ b/x11-misc/notify-osd/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<upstream>
diff --git a/x11-misc/notify-osd/notify-osd-0.9.34-r1.ebuild b/x11-misc/notify-osd/notify-osd-0.9.34-r2.ebuild
index 6a1096cc8f5b..789a23455ea9 100644
--- a/x11-misc/notify-osd/notify-osd-0.9.34-r1.ebuild
+++ b/x11-misc/notify-osd/notify-osd-0.9.34-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools gnome2-utils savedconfig
DESCRIPTION="Canonical's on-screen-display notification agent"
@@ -13,7 +13,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="minimal"
-COMMON_DEPEND="
+RDEPEND="
+ gnome-base/gsettings-desktop-schemas
+ !minimal? ( x11-themes/notify-osd-icons )
+"
+DEPEND="
+ dev-util/glib-utils
+ gnome-base/gnome-common
+ x11-base/xorg-proto
+ virtual/pkgconfig
>=dev-libs/dbus-glib-0.98
>=dev-libs/glib-2.16:2
>=x11-libs/gtk+-3.2:3
@@ -24,19 +32,12 @@ COMMON_DEPEND="
!x11-misc/notification-daemon
!x11-misc/qtnotifydaemon
"
-RDEPEND="${COMMON_DEPEND}
- gnome-base/gsettings-desktop-schemas
- !minimal? ( x11-themes/notify-osd-icons )
-"
-DEPEND="${COMMON_DEPEND}
- dev-util/glib-utils
- gnome-base/gnome-common
- x11-base/xorg-proto
- virtual/pkgconfig
-"
RESTRICT="test" # virtualx.eclass: 1 of 1: FAIL: test-modules
+# Patch is upstreamed here: https://answers.launchpad.net/notify-osd/+question/704024
+PATCHES=( "${FILESDIR}/${P}-fix-integer-conversion.patch" )
+
src_prepare() {
default
sed -i -e 's:noinst_PROG:check_PROG:' tests/Makefile.am || die
@@ -56,16 +57,15 @@ src_install() {
}
pkg_preinst() {
- gnome2_icon_savelist
gnome2_schemas_savelist
}
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
gnome2_schemas_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
gnome2_schemas_update
}