summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/qps/qps-2.8.0.ebuild')
-rw-r--r--x11-misc/qps/qps-2.8.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/qps/qps-2.8.0.ebuild b/x11-misc/qps/qps-2.8.0.ebuild
new file mode 100644
index 000000000000..67bba6929681
--- /dev/null
+++ b/x11-misc/qps/qps-2.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI Process Manager"
+HOMEPAGE="https://lxqt-project.org/"
+SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2 GPL-2+ LGPL-2.1+ QPL-1.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~loong ~riscv x86"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.13.0
+"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ >=lxqt-base/liblxqt-1.4:=
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}