summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/qtnotifydaemon')
-rw-r--r--x11-misc/qtnotifydaemon/Manifest1
-rw-r--r--x11-misc/qtnotifydaemon/files/qtnotifydaemon-1.0.14-build.patch32
-rw-r--r--x11-misc/qtnotifydaemon/metadata.xml13
-rw-r--r--x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild36
4 files changed, 82 insertions, 0 deletions
diff --git a/x11-misc/qtnotifydaemon/Manifest b/x11-misc/qtnotifydaemon/Manifest
new file mode 100644
index 000000000000..fe3d8e9a1a94
--- /dev/null
+++ b/x11-misc/qtnotifydaemon/Manifest
@@ -0,0 +1 @@
+DIST qtnotifydaemon_1.0.14.orig.tar.gz 1136779 SHA256 1e5a91c8b1f4a9954842a69c2e41bf8fbccad4dcdc115797863098f800be54b5 SHA512 409f911be7d0e55f8a9f23db67ad6eefac1d215c598f54bab35bd704feee3a68ae21a3c416bd8848aacbdd82ca751ea1170c566d5615d4ac8a30adb87d487b8f WHIRLPOOL b73f19aa3e18dec8dd952768b14a0fb5defeee0c58c27fce50ca53bb5602c5fe8dfe15f79c5e727657ae35efae20e38e9720953e1f102c0c46717f475f830445
diff --git a/x11-misc/qtnotifydaemon/files/qtnotifydaemon-1.0.14-build.patch b/x11-misc/qtnotifydaemon/files/qtnotifydaemon-1.0.14-build.patch
new file mode 100644
index 000000000000..0aebc851c727
--- /dev/null
+++ b/x11-misc/qtnotifydaemon/files/qtnotifydaemon-1.0.14-build.patch
@@ -0,0 +1,32 @@
+Fixes build with GCC 4.7, as well as the gold linker.
+
+--- main.cpp
++++ main.cpp
+@@ -22,6 +22,7 @@
+ #include <signal.h>
+ #include <sys/stat.h>
+ #include <pwd.h>
++#include <unistd.h>
+ #include "dbus.h"
+ #include "notifywidget.h"
+ #include "notifyarea.h"
+--- notifyarea.cpp
++++ notifyarea.cpp
+@@ -22,6 +22,7 @@
+ #include <QSystemTrayIcon> //alex
+ #include <QDesktopWidget>
+ #include <fstream>
++#include <unistd.h>
+ #include "notifyarea.h"
+ #include "notifywidget.h"
+ #include "dbus.h"
+--- qtnotifydaemon.pro
++++ qtnotifydaemon.pro
+@@ -13,6 +13,7 @@
+ INCLUDEPATH += .
+ QT += dbus
+ RESOURCES += images.qrc
++LIBS += -lX11
+
+ # Input
+ SOURCES += main.cpp notifywidget.cpp dbus.cpp notifyarea.cpp message.cpp
diff --git a/x11-misc/qtnotifydaemon/metadata.xml b/x11-misc/qtnotifydaemon/metadata.xml
new file mode 100644
index 000000000000..e44f13e08d2e
--- /dev/null
+++ b/x11-misc/qtnotifydaemon/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">qtnotifydaemon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild b/x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild
new file mode 100644
index 000000000000..da339ae7d4e0
--- /dev/null
+++ b/x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit qt4-r2
+
+DESCRIPTION="A flexible and configurable notification daemon"
+HOMEPAGE="http://sourceforge.net/projects/qtnotifydaemon/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qt3support:4
+ !x11-misc/notification-daemon
+ !x11-misc/notify-osd"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+PATCHES=( "${FILESDIR}/${P}-build.patch" )
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/share/dbus-1/services
+ doins org.freedesktop.Notifications.service
+
+ doman debian/${PN}.1
+}