summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/rednotebook/rednotebook-1.8.0.ebuild')
-rw-r--r--x11-misc/rednotebook/rednotebook-1.8.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/rednotebook/rednotebook-1.8.0.ebuild b/x11-misc/rednotebook/rednotebook-1.8.0.ebuild
new file mode 100644
index 000000000000..d862a3c0b542
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-1.8.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="libyaml spell"
+
+RDEPEND="
+ dev-python/pyyaml[libyaml?,${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.13[${PYTHON_USEDEP}]
+ >=dev-python/pywebkitgtk-1.1.5[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ spell? ( dev-python/gtkspell-python[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ ! use spell && epatch "${FILESDIR}/${PN}-1.6.5-disable-spell.patch"
+}