summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/rofi-calc/rofi-calc-2.0.0.ebuild')
-rw-r--r--x11-misc/rofi-calc/rofi-calc-2.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/rofi-calc/rofi-calc-2.0.0.ebuild b/x11-misc/rofi-calc/rofi-calc-2.0.0.ebuild
new file mode 100644
index 000000000000..ce53ee1c9e75
--- /dev/null
+++ b/x11-misc/rofi-calc/rofi-calc-2.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Do live calculations in rofi!"
+HOMEPAGE="https://github.com/svenstaro/rofi-calc"
+SRC_URI="https://github.com/svenstaro/rofi-calc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ x11-misc/rofi
+ >=sci-libs/libqalculate-2.0
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf -i
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}