summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/simpleswitcher/simpleswitcher-99999999.ebuild')
-rw-r--r--x11-misc/simpleswitcher/simpleswitcher-99999999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/simpleswitcher/simpleswitcher-99999999.ebuild b/x11-misc/simpleswitcher/simpleswitcher-99999999.ebuild
new file mode 100644
index 000000000000..3430c6607dc1
--- /dev/null
+++ b/x11-misc/simpleswitcher/simpleswitcher-99999999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="lightweight EWMH window switcher with features and looks of dmenu"
+HOMEPAGE="https://github.com/seanpringle/simpleswitcher"
+EGIT_REPO_URI="${HOMEPAGE}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXres
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}