summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/sux/sux-1.0.1.ebuild')
-rw-r--r--x11-misc/sux/sux-1.0.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-misc/sux/sux-1.0.1.ebuild b/x11-misc/sux/sux-1.0.1.ebuild
new file mode 100644
index 000000000000..257dc59f7c9e
--- /dev/null
+++ b/x11-misc/sux/sux-1.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="\"su\" wrapper which transfers X credentials"
+HOMEPAGE="http://fgouget.free.fr/sux/sux-readme.shtml"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ppc sparc x86"
+
+RDEPEND="x11-apps/xauth"
+DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-xauth-and-home.patch
+)
+
+src_install() {
+ dobin ${PN}{,term}
+ dodoc TODO
+ newdoc debian/changelog Debian.changelog
+ doman debian/${PN}{,term}.1
+}