summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/tint2/files')
-rw-r--r--x11-misc/tint2/files/0.12.12-fix-compilation-without-svg.patch18
-rw-r--r--x11-misc/tint2/files/0.12.12-no-hardcode-update-icon-cache.patch34
-rw-r--r--x11-misc/tint2/files/0.12.12-relax-pango-includes.patch26
3 files changed, 78 insertions, 0 deletions
diff --git a/x11-misc/tint2/files/0.12.12-fix-compilation-without-svg.patch b/x11-misc/tint2/files/0.12.12-fix-compilation-without-svg.patch
new file mode 100644
index 000000000000..c6da687baca8
--- /dev/null
+++ b/x11-misc/tint2/files/0.12.12-fix-compilation-without-svg.patch
@@ -0,0 +1,18 @@
+From 2c42a787257e0801b8454fd8960d6794831cedea Mon Sep 17 00:00:00 2001
+From: o9000 <mrovi9000@gmail.com>
+Date: Sat, 8 Oct 2016 15:02:28 +0200
+Subject: Fix compilation with ENABLE_RSVG=OFF (fixes issue #602)
+
+
+diff --git a/src/launcher/launcher.c b/src/launcher/launcher.c
+index 0b4172f..0052e90 100644
+--- a/src/launcher/launcher.c
++++ b/src/launcher/launcher.c
+@@ -30,7 +30,6 @@
+ #include <glib/gi18n.h>
+ #include <glib.h>
+ #include <glib/gstdio.h>
+-#include <gdk-pixbuf/gdk-pixbuf.h>
+ #include <sys/types.h>
+
+ #include "window.h"
diff --git a/x11-misc/tint2/files/0.12.12-no-hardcode-update-icon-cache.patch b/x11-misc/tint2/files/0.12.12-no-hardcode-update-icon-cache.patch
new file mode 100644
index 000000000000..21a80eb36d43
--- /dev/null
+++ b/x11-misc/tint2/files/0.12.12-no-hardcode-update-icon-cache.patch
@@ -0,0 +1,34 @@
+From 6306f9920f639cf092ca3f1935ac7aa202f78c86 Mon Sep 17 00:00:00 2001
+From: Yuri Konotopov <ykonotopov@gnome.org>
+Date: Fri, 13 Jan 2017 19:06:43 +0400
+Subject: [PATCH] cmake: do not hardcode icon cache update
+
+---
+ CMakeLists.txt | 1 -
+ src/tint2conf/CMakeLists.txt | 1 -
+ 2 files changed, 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b4a1089..ef06393 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -241,7 +241,6 @@ set_target_properties( tint2 PROPERTIES LINK_FLAGS "-pthread -fno-strict-aliasin
+ install( TARGETS tint2 DESTINATION bin )
+ install( FILES tint2.svg DESTINATION ${DATADIR}/icons/hicolor/scalable/apps )
+ install( FILES tint2.desktop DESTINATION ${DATADIR}/applications )
+-install( CODE "execute_process(COMMAND gtk-update-icon-cache -f -t ${DATADIR}/icons/hicolor WORKING_DIRECTORY ${CMAKE_INSTALL_PREFIX})" )
+ install( FILES themes/tint2rc DESTINATION ${SYSCONFDIR}/xdg/tint2 )
+ install( FILES default_icon.png DESTINATION ${DATADIR}/tint2 )
+ install( FILES AUTHORS ChangeLog README.md doc/tint2.md doc/manual.html doc/readme.html DESTINATION ${DOCDIR} )
+diff --git a/src/tint2conf/CMakeLists.txt b/src/tint2conf/CMakeLists.txt
+index 9595f6a..fd616fa 100644
+--- a/src/tint2conf/CMakeLists.txt
++++ b/src/tint2conf/CMakeLists.txt
+@@ -72,4 +72,3 @@ add_subdirectory(po)
+ install( TARGETS tint2conf DESTINATION bin )
+ install( FILES tint2conf.svg DESTINATION ${DATADIR}/icons/hicolor/scalable/apps )
+ install( FILES tint2conf.desktop DESTINATION ${DATADIR}/applications )
+-install( CODE "execute_process(COMMAND gtk-update-icon-cache -f -t ${DATADIR}/icons/hicolor WORKING_DIRECTORY ${CMAKE_INSTALL_PREFIX})" )
+--
+2.10.2
+
diff --git a/x11-misc/tint2/files/0.12.12-relax-pango-includes.patch b/x11-misc/tint2/files/0.12.12-relax-pango-includes.patch
new file mode 100644
index 000000000000..e9e40f305b34
--- /dev/null
+++ b/x11-misc/tint2/files/0.12.12-relax-pango-includes.patch
@@ -0,0 +1,26 @@
+From c3a86e185d548e11bb12bc766a58fd3b617c1c46 Mon Sep 17 00:00:00 2001
+From: o9000 <mrovi9000@gmail.com>
+Date: Sun, 18 Sep 2016 12:53:59 +0200
+Subject: [PATCH] Fix include (fixes issue #596)
+
+---
+ src/config.c | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/src/config.c b/src/config.c
+index a831ece..13f3b7b 100644
+--- a/src/config.c
++++ b/src/config.c
+@@ -31,8 +31,7 @@
+ #include <string.h>
+ #include <ctype.h>
+ #include <glib/gstdio.h>
+-#include <pango/pangocairo.h>
+-#include <pango/pangoxft.h>
++#include <pango/pango-font.h>
+ #include <Imlib2.h>
+
+ #include "config.h"
+--
+libgit2 0.24.0
+