summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/touchcal/touchcal-0.80.ebuild')
-rw-r--r--x11-misc/touchcal/touchcal-0.80.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/x11-misc/touchcal/touchcal-0.80.ebuild b/x11-misc/touchcal/touchcal-0.80.ebuild
index c20620986a9f..eed48ddb112c 100644
--- a/x11-misc/touchcal/touchcal-0.80.ebuild
+++ b/x11-misc/touchcal/touchcal-0.80.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Touchscreen calibration utility"
HOMEPAGE="http://touchcal.sourceforge.net/"
@@ -19,3 +21,9 @@ DEPEND="
x11-libs/libXinerama
"
RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ local PKGCONFIG="$(tc-getPKG_CONFIG)"
+ emake LDADD="$(${PKGCONFIG} --libs ncurses)"
+}