summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xac')
-rw-r--r--x11-misc/xac/Manifest1
-rw-r--r--x11-misc/xac/files/x86-biosfix.patch40
-rw-r--r--x11-misc/xac/metadata.xml11
-rw-r--r--x11-misc/xac/xac-0.6_pre4.ebuild57
4 files changed, 109 insertions, 0 deletions
diff --git a/x11-misc/xac/Manifest b/x11-misc/xac/Manifest
new file mode 100644
index 000000000000..5e6473b8dd7c
--- /dev/null
+++ b/x11-misc/xac/Manifest
@@ -0,0 +1 @@
+DIST xac-0.6_pre4.tar.bz2 37409 SHA256 ff34e1e6e7027a22e712307e3832423b512af894e8ad9678e2f5d022a699a4d4
diff --git a/x11-misc/xac/files/x86-biosfix.patch b/x11-misc/xac/files/x86-biosfix.patch
new file mode 100644
index 000000000000..918cdf131d55
--- /dev/null
+++ b/x11-misc/xac/files/x86-biosfix.patch
@@ -0,0 +1,40 @@
+diff -u -B -r1.1 -r1.2
+--- src/bioscall.h 25 Aug 2006 19:48:26 -0000 1.1
++++ src/bioscall.h 30 Sep 2009 15:05:49 -0000 1.2
+@@ -1,6 +1,8 @@
+ #ifndef bioscall_h
+ #define bioscall_h
+
++#include "int10defs.h"
++
+ /* Print some of the interesting parts of a vm86_regs structure. */
+ void dump_regs(struct vm86_regs *regs);
+
+diff -u -B -r1.1 -r1.2
+--- src/lrmi.h 25 Aug 2006 19:48:26 -0000 1.1
++++ src/lrmi.h 30 Sep 2009 15:05:49 -0000 1.2
+@@ -26,6 +26,8 @@
+ #ifndef LRMI_H
+ #define LRMI_H
+
++#include "int10defs.h"
++
+ #if defined(__i386__) && (defined(__linux__) || defined(__NetBSD__) \
+ || defined(__FreeBSD__) || defined(__OpenBSD__))
+
+diff -Naur
+--- src/int10defs.h
++++ src/int10defs.h 30 Sep 2009 15:05:49 -0000
+@@ -0,0 +1,12 @@
++/* Fix missing INT10 defines */
++#ifndef IF_MASK
++#define TF_MASK 0x00000100
++#define IF_MASK 0x00000200
++#define IOPL_MASK 0x00003000
++#define NT_MASK 0x00004000
++#define VM_MASK 0x00020000
++#define AC_MASK 0x00040000
++#define VIF_MASK 0x00080000 /* virtual interrupt flag */
++#define VIP_MASK 0x00100000 /* virtual interrupt pending */
++#define ID_MASK 0x00200000
++#endif
diff --git a/x11-misc/xac/metadata.xml b/x11-misc/xac/metadata.xml
new file mode 100644
index 000000000000..487b7c36eb44
--- /dev/null
+++ b/x11-misc/xac/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>josejx@gentoo.org</email>
+<name>Joseph Jezak</name>
+</maintainer>
+<longdescription lang="en">
+X.org autoconfiguration tool written in python.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-misc/xac/xac-0.6_pre4.ebuild b/x11-misc/xac/xac-0.6_pre4.ebuild
new file mode 100644
index 000000000000..398aeff936bf
--- /dev/null
+++ b/x11-misc/xac/xac-0.6_pre4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs eutils multilib
+
+DESCRIPTION="Xorgautoconfig (xac) generates configuration files for X.org"
+HOMEPAGE="http://dev.gentoo.org/~josejx/xac.html"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ppc ppc64 ~x86"
+SLOT="0"
+IUSE="livecd"
+DEPEND=">=dev-lang/python-2.3
+ sys-apps/pciutils"
+RDEPEND=">=dev-lang/python-2.3
+ x11-base/xorg-server"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ ### Replace /usr/lib/xac with libdir version
+ sed -i "s:/usr/lib/xac:/usr/$(get_libdir)/xac:" xac
+
+ ### Fix the x86 bios call with newer glibc
+ epatch "${FILESDIR}/x86-biosfix.patch"
+
+ ### Make setup.py executable
+ chmod +x "${S}/src/setup.py"
+}
+
+src_compile() {
+ ### Compile the C bindings
+ cd "${S}"/src
+ ./setup.py build || die "Failed to build the C modules"
+}
+
+src_install() {
+ local xac_base="/usr/$(get_libdir)/xac"
+
+ dosbin "${S}"/xac
+
+ ### Install the C mods
+ cd "${S}"/src
+ ./setup.py install --root "${D}" || die "Failed to install the C modules"
+
+ dodir "${xac_base}"
+ insinto ${xac_base}
+ doins "${S}"/py/*
+
+ ### Only install the init scripts if livecd is enabled
+ if use livecd; then
+ newinitd "${S}"/xac.init xac
+ newconfd "${S}"/xac.conf xac
+ fi
+}