summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xcape/files/xcape-1.2-makefile.patch')
-rw-r--r--x11-misc/xcape/files/xcape-1.2-makefile.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-misc/xcape/files/xcape-1.2-makefile.patch b/x11-misc/xcape/files/xcape-1.2-makefile.patch
new file mode 100644
index 000000000000..06d4d04cdf50
--- /dev/null
+++ b/x11-misc/xcape/files/xcape-1.2-makefile.patch
@@ -0,0 +1,27 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,19 +1,16 @@
+ INSTALL=install
+-PREFIX=/usr
+-MANDIR?=/local/man/man1
++PREFIX=$(EPREFIX)/usr
++MANDIR?=/share/man/man1
+
+ TARGET := xcape
+
+ CFLAGS += -Wall
+-CFLAGS += `pkg-config --cflags xtst x11`
+-LDFLAGS += `pkg-config --libs xtst x11`
+-LDFLAGS += -pthread
++CFLAGS += `$(PKG_CONFIG) --cflags xtst x11`
++LDLIBS += `$(PKG_CONFIG) --libs xtst x11`
++LDLIBS += -pthread
+
+ all: $(TARGET)
+
+-$(TARGET): xcape.c
+- $(CC) $(CFLAGS) -o $@ $< $(LDFLAGS)
+-
+ install:
+ $(INSTALL) -d -m 0755 $(DESTDIR)$(PREFIX)/bin
+ $(INSTALL) -d -m 0755 $(DESTDIR)$(PREFIX)$(MANDIR)